Formatted text copied from a desktop application (i.e. Word, TextEdit, etc.) looses formatting when pasted into a designMode enabled element.

RESOLVED DUPLICATE of bug 428096

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 428096
11 years ago
9 years ago

People

(Reporter: Steven Elliott, Unassigned)

Tracking

2.0 Branch
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

When I copy formatted text from Word, TextEdit etc. and then  try to paste the text into a designMode enabled element (i.e. iframe) the text is pasted without formatting.

When I perform the same operation in Windows, FF pastes correctly formatted text.

When I perform the same operation in OSX with Safari the text is pasted with the correct formatting.

FireFox will copy/paste formatted text correctly IF THE TEXT IS COPIED FROM FIREFOX ITSELF.  In otherwords FF will retain formatting on OSX only if the text is copied/pasted from the FF application.


Reproducible: Always

Steps to Reproduce:
1.Create a simple HTML document with a designMode enabled element (i.e. iframe)
2.Copy formatted text from a desktop application (i.e. Word, TextEdit)
3.Paste the text into the designMode enabled element.
Actual Results:  
Text is pasted into FF but with no formatting.

Expected Results:  
Text is pasted with copied formatting.
(Reporter)

Comment 1

11 years ago
Created attachment 268427 [details]
test case

Comment 2

10 years ago
I can confirm this bug, would like to see a solution for it.

Updated

10 years ago
Blocks: 424615

Comment 3

10 years ago
Same as bug 428096?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Hardware: Macintosh → All
Resolution: --- → DUPLICATE
Version: unspecified → 2.0 Branch
Duplicate of bug: 428096

Comment 5

9 years ago
If you haven't voted for the duplicate of this bug (bug #428096), please do so.

https://bugzilla.mozilla.org/votes.cgi?action=show_user&bug_id=428096#vote_428096

I am hoping to raise the attention and importance of this issue and hopefully get the HTML, styl, rtf, img function of the Firefox clipboard finally fixed.

Thanks for helping.
You need to log in before you can comment on or make changes to this bug.