After new mail received the "Today" group name changes to "Old mail"

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Ferenc Lengyel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-08-30)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Thunderbird 2.0.0.4

Mail sorting set to Date/Descending, Grouped by sort G
POP3 set for downloading headers only.

After opening Thunderbird, everything looks OK. After new mail received, it is still OK, but when I download message body, the "Today" group name changes to "Old mail". The problem lasts until folder selection change (for example I choose Sent mail folder and then again Inbox).

Reproducible: Always

Steps to Reproduce:
1.Mail sorting Date/Descending, Group by sort
2.POP3/Headers only
3.get new mail + download body
Actual Results:  
"Today" group name changes to "Old mail"

Expected Results:  
"Today" group name does not change

Comment 1

10 years ago
Can't reproduce with 2.0.0.12 or trunk 3.0a1pre (2008040204) with IMAP account at least.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(In reply to comment #1)
> Can't reproduce with 2.0.0.12 or trunk 3.0a1pre (2008040204) with IMAP account
> at least.
> 

Reopening. I can't test this at the moment, but comment 0 clearly states POP 3 Headers. You can't close this on the basis of an IMAP test.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
WFM

test on pop3 account

using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090526 Lightning/1.0pre Shredder/3.0b3pre ID:20090526031655
Ferenc can you give http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/ a try and tell us if the issue is fixed for you too ?
Summary: After new mail received the "Toady" group name changes to "Old mail" → After new mail received the "Today" group name changes to "Old mail"

Updated

9 years ago
Whiteboard: closeme-2009-08-30

Updated

9 years ago
Whiteboard: closeme-2009-08-30 → closeme 2009-08-30
(Reporter)

Comment 5

9 years ago
Hello Ludovic,

the you've posted doesn't work, so I've tried with the most current version 2.0.0.22. The behaviour is exactly the same:

1. I create a POP3 account
2. Download the current messages
3. Then sort the messages by Date column descending
4. Menu View -> Sort by -> Grouped by Sort G
5. Then I sent a test message from another account
6. when new message arrives, it looks ok, but after I download body, the group header changes from "Today" to "Old mail"

The issue has low severity for me, I've just tried to participate in development ... :-)

thx,
Ferenc
I meant http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/  :-) sorry might already been fixed - that's why I'm asking.
(Reporter)

Comment 7

9 years ago
I cannot test it because on this version I cannot view any messages in POP3 mode. It is maybe a different bug.

F.
(In reply to comment #7)
> I cannot test it because on this version I cannot view any messages in POP3
> mode. It is maybe a different bug.

Make sure it's not a firewall issue (see http://kb.mozillazine.org/Firewalls)
(Reporter)

Comment 9

9 years ago
It seems that it works on Win XP, but doesn't work on Vista.

The original bug is fixed.

Thank you.

Ferenc
RESO WFM per comment 9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.