Elements with coordinates >= 32768 not drawn

RESOLVED DUPLICATE of bug 315383

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 315383
11 years ago
11 years ago

People

(Reporter: Swatinem, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070614 Minefield/3.0a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070614 Minefield/3.0a6pre

Elements which include coordinates >= 32768 do not render.
<rect x="0" y="0" width="32768" height="32768"/> For example is not rendered.
Using scale seems to fix the problem. So <rect x="0" y="0" width="32768" height="32768" transform="scale(0.5)"/> is rendered correctly.

I found a few similar bugs which deal with html content. I don't know if these issues are related so I opened a new bug for SVG. Excuse me if this is a real dupe though.

Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 315383
You need to log in before you can comment on or make changes to this bug.