Status Bar should show link target (based on target attribute or keyboard modifiers being held)

RESOLVED DUPLICATE of bug 279223

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 279223
11 years ago
11 years ago

People

(Reporter: Dick Guertin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

First, I had to classify this as a General Component because Status Bar isn't listed as a Component.

The Status Bar at the bottom of a page shows where a link will go when you mouse over the link on the page. Safari adds a few things that I've found are very helpful. If the link has target="_blank", Safari adds "in a new window". I'm on a Mac OSX 10.4.9 system with Firefox 2.0.0.4, and there's no difference between a link with target="_blank" and one without it. If I hold down my Command key in Safari, it also adds "in a new window". Firefox does not. But even more bizarre, if there is a target="_blank" AND I hold down my Command key, when I click the link I get TWO tabs opened, on for the target="_blank", and one for the Command key. That causes a lot of load time when I've got a 0 Cache setting.

Furthermore, in Safari, if I hold down the Option key, Safari changes the beginning of the Status Bar information by saying "Download:", which is exactly what happens when I click the link. Firefox adds no such information, so I'm not sure what will happen. So I'm requesting an improvement in the Status Bar information. Tell us if it will Download, or be opened in a new window or tab. The whole idea of the Status Bar is to give us information. I wouldn't hold down the Command key if I knew in advance that the link would open a new tab because of target="_blank". 

Reproducible: Always

Steps to Reproduce:
1.Select a link
2.View the Status Bar
3.Press the Option or Command key
Actual Results:  
Nothing changes in the Status Bar, although the result WILL be different.

Expected Results:  
Status Bar should show the new status, such as Download or New Tab.

Do not know if this is the same in Windows, but I suspect this is true across all versions of Firefox.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Summary: Status Bar does not show enough information → Status Bar should show link target (based on target attribute or keyboard modifiers being held)
Duplicate of bug: 279223
You need to log in before you can comment on or make changes to this bug.