downloaded update attempts to apply after manual update

RESOLVED DUPLICATE of bug 318855

Status

defect
RESOLVED DUPLICATE of bug 318855
12 years ago
10 years ago

People

(Reporter: preston, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-08-10)

Reporter

Description

12 years ago
User-Agent:       Opera/9.21 (Windows NT 5.1; U; en)
Build Identifier: version 2.0.0.4 (20070604)

On a machine without Administrator access, a downloaded update will attempt to install (and fail) even after the administrator for the machine manually installs the update to the most recent version. A simple version check of the downloaded file would prevent the application for continuing to attempt the update.

Reproducible: Always

Steps to Reproduce:
1. With Thunderbird 2.0.0.0 installed, log in as a non-administrator account.
2. Thunderbird will download update 2.0.0.4 and attempt to install, failing.
3. Log in as administrator and install update manually without going through Thunderbird.
4. Log back in to non-administrator account and watch it fail to install update after ever invocation of Thunderbird.


Expected Results:  
Software should determine that the update version download and the current version installed are the same and not attempt the update.
Version: unspecified → 2.0

Comment 1

11 years ago
Yes, that sounds familiar. Does it still happen with the new version? Which failure message do you get?
Reporter any reply to comment #1?
Whiteboard: closeme-2009-08-10

Comment 3

10 years ago
This is the same with Firefox 3 auto update.

I could think of an other behaviour of Mozilla Firefox/Thundebird, if it is not harder to code than "Expected Results".
a) Check if the installed version is the same _or higher_ than the update.   
   Because you can log-in and try to install weeks after the download.
b) Check user or file system privileges before trying to install.
c) Check user or file system privileges before even trying to download.

However - its very nasty that most times, I have to kill this Mozilla-wants-but-can't-and-tries-again update loop in the task manager!

It's a little unfortunate, that auto-update is activated for every user - no matter if he has the admin rights to install the downloaded updates.
Whiteboard: closeme-2009-08-10 → closeme 2009-08-10

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 318855
You need to log in before you can comment on or make changes to this bug.