If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

checksetup.pl alter table for namedqueries error

RESOLVED INVALID

Status

()

Bugzilla
Installation & Upgrading
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Matt Arnett, Unassigned)

Tracking

PowerPC
Mac OS X

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 2.22.1

My CVS upgrade from 2.22.1 to 3 appears to have gone flawlessly (numerous times), but when I run checksetup.pl I receive an error when trying to rename ./bugzilla/#sql-757f_acd to ./bugzilla/namedqueries. I have tried to manually change namedqueries from MYISAM to INNODB from the command line, and get the same 1025 error. Is this an issue with mySQL v14.12 dist. 5.0.32, or something incorrect with the format of the namedqueries table (since I can change other Bugzilla tables just fine)? We are running on Debian kernel 2.6.

Reproducible: Always

Steps to Reproduce:
1. CVSROOT=:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot
2. export CVSROOT
3. cvs login
4. anonymous
5. cvs checkout -d Bugzilla -rBugzilla_Stable Bugzilla
6. cvs update -A -dP
7. cd /usr/lib/cgi-bin/bugzilla/Bugzilla
8. Edit ./localconfig for webservergroup, db_name, db_user, & db_pass
9. ./checksetup.pl
Actual Results:  
Checking for           DBD-mysql (v2.9003) ok: found v3.0008 
Checking for           MySQL (v4.1.2)  ok: found v5.0.32-Debian_3-log

Bugzilla now uses the InnoDB storage engine in MySQL for most tables.
Converting tables to InnoDB:
Converting table namedqueries... DBD::mysql::db do failed: Error on rename of './bugzilla/#sql-757f_ad0' to './bugzilla/namedqueries' (errno: 150) at Bugzilla/DB/Mysql.pm line 324
        Bugzilla::DB::Mysql::bz_setup_database('Bugzilla::DB::Mysql=HASH(0x917bddc)') called at ./checksetup.pl line 145

Expected Results:  
Converted all of the tables to INNODB and completed the installation.

Nothing else that I can think of. If there is a work-around, I would be more than pleased to know what it is. Thanks!

Comment 1

10 years ago
First, I hope you know that you upgraded to the highly unstable 3.1, not to 3.0.

Secondly, this isn't actually a problem in Bugzilla. errno 150 means that there's some problem with Foreign Keys, and there were *no* foreign keys in Bugzilla before 3.1, so you must have modified your DB manually or had some failed upgrades in the past that corrupted your DB.

In any case, this is a support question and should be dealt with on the support list described here:

http://www.bugzilla.org/support/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Version: unspecified → 3.1
You need to log in before you can comment on or make changes to this bug.