Closed Bug 384690 Opened 15 years ago Closed 15 years ago

bookmarks are lost/inaccessible (in bookmarks menu)

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 3 alpha6

People

(Reporter: Peter6, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070615 Minefield/3.0a6pre ID:2007061522

repro:

open the latest (hourly) build
open bookmarks menu

result:

only recently opened bookmarks will display with no option to "unhide" older bookmarks/bookmark folders 

regressionwindow:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1181954340&maxdate=1181960459

bug 337855
more from bookmarks menu ...
can't open Bookmarks Toolbar Folder
Live bookmarks aren't displayed
more from bookmarks menu...
subfolders aren't displayed at all , there's only a thingy top-right of the folder name.

OS shouldn't be just Windows XP, it happens on Linux as well.
Summary: bookmarks are lost/inaccessible → bookmarks are lost/inaccessible (in bookmarks menu)
Bookmarks in folder without subfolder are displaying fine for me. Those with subfolders seems to cause the problem.
Error: this._containerNodesMap has no properties
Source File: chrome://browser/content/places/menu.xml
Line: 198
Trying to add a livebookmark into a subfolder causes the errors:
*** getSiteURI failed: 2147942487
*** siteURIString: undefined
*** getSiteURI failed: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIAnnotationService.getItemAnnotationString]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: file:///usr/lib/firefox/components/nsLivemarkService.js :: LS_getSiteURI :: line 686"  data: no]
*** siteURIString: undefined

and http://img524.imageshack.us/img524/497/screenshoton0.png
Attached patch workaround (obsolete) — Splinter Review
Assignee: nobody → mano
Status: NEW → ASSIGNED
Attachment #268625 - Flags: review?(dietrich)
Comment on attachment 268625 [details] [diff] [review]
workaround

the changes look ok, r=me. however, either keep this open, or file a new bug for the root cause of this problem.
Attachment #268625 - Flags: review?(dietrich) → review+
Attached patch should work nowSplinter Review
Attachment #268625 - Attachment is obsolete: true
Attachment #268632 - Flags: review?(dietrich)
Comment on attachment 268632 [details] [diff] [review]
should work now

r=me. looks ok, given the testing code is removed per irc. windows is still building, so not tested there yet.
Attachment #268632 - Flags: review?(dietrich) → review+
anyone care to have a nightly respin after this 
Checking in browser/components/places/content/menu.xml;
/cvsroot/mozilla/browser/components/places/content/menu.xml,v  <--  menu.xml
new revision: 1.74; previous revision: 1.73
done
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 alpha6
This may have caused a slight leak increase? Rlk is up to 3.07KB
Blocks: 384731
Depends on: 384763
No longer depends on: 384763
The problem still partially exist :
- drag a bookmark from the toolbar to menu
- click on bookmarks menu
- bookmarks inside folders are no longer accessible
- close firefox, open it bookmarks are accessible again

Note :
When the problem occurs it seems to not affect the bookmark toolbar.
I'm not sure if the problem occurs for folder without subfolders. (I have no folders without subfolders)
I forgot to mention, I'm using the latest nightly build : 2007061804
Please file a bug and cc me, thanks.
Verified in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/200707110404 Minefield/3.0a7pre.
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.