Profile Manager starts then hangs - dialog box not appearing

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: jmjeffery, Unassigned)

Tracking

({hang, qawanted, regression})

Trunk
x86
Windows Vista
hang, qawanted, regression
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070617 Minefield/3.0a6pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070617 Minefield/3.0a6pre Firefox/3.0

This seems to have regressed between 
2007-06-12 hour 4 & 2007-06-12 hour 6 build 

Possible Bonsai range:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-06-12+02%3A00%3A00&maxdate=2007-06-12+07%3A00%3A00&cvsroot=%2Fcvsroot

Another person in the Builds forums is having the same issue with the PM.
They are using an Athlon CPU as I am, running Vista.  Others in the forum are reporting the PM works for them, so it may be a hardware/OS/CPU problem.

Reproducible: Always

Steps to Reproduce:
1. Use any build after 2007-06-12 Hour 6 
2. Profile Manager will not display dialog box, only leaves a Ghost running 
consuming approx 13 meg RAM. 
3. Kill the Process with the TaskManager 
Regular startup of the builds seem to run OK, its only issue is with the PM.
Actual Results:  
PM will not display the dialog box.

Expected Results:  
PM Should start.

Comment 1

11 years ago
i have exact same promblem
(Reporter)

Updated

11 years ago
Keywords: regression
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Not on WinXP with an AMD Athlon here.

Comment 3

11 years ago
need to see if we can find somone else running vista with athlon 

Updated

11 years ago
Keywords: qawanted

Comment 4

11 years ago
For those of you who are seeing this, can you reproduce with a clean profile as well?
(In reply to comment #4)
> For those of you who are seeing this, can you reproduce with a clean profile as
> well?
> 

Yes.  I completely dumped the Install directory including all plugins, and the Profiles on my system.  Then I went through and cleaned the registry of anything I could find named: Mozilla/Minefield/Firefox and started fresh.. and the PM still hung on start. 


Adam, this happens for me in Windows whenever I click URL from another application (ie. TBird, XChat), or if I try to double-click a file that is set to open in Firefox by default (ie. image, url shortcut).

This happens on a clean profile and in safemode but only when profile manager is set to launch at startup, or if I have an instance of firefox already running.


Flags: blocking-firefox3?

Comment 7

11 years ago
i even tried running Firefox profile manger in vista safemode

Updated

11 years ago
Blocks: 345517

Comment 8

11 years ago
Could you please try removing compreg.dat and xpti.dat from appdir/components?
Well if that's not disgusting.... I went to remove the two files as suggested and thought, I'll just give this a try before I delete/rename them.. and with today's build, which I never gave a thought of testing... works OK, today I can pull up the PM just fine...  A mystery begins..

There is no 'components' folder in appdir/ the two files are located in the working profile under the appdir/....

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070618 Minefield/3.0a6pre Firefox/3.0 ID:2007061804

Comment 10

11 years ago
odd i deleted those files still same problem

Comment 11

11 years ago
from the looks of things this bug is gonna be hard to pinpoint 

anthany are you suing vista or xp maybe help make sure this is vista only problem also what processor are you using since so far only ppl ive talked with use amd
Gabe, I have only seen this on XP, I have not extensively tried to reproduce it on Vista.

Comment 13

11 years ago
ok correction gonna be really hard to pinpoint now that we know its not vista only
We don't block on Profile Manager bugs, as this is considered a tester/developer feature.
Flags: blocking-firefox3? → blocking-firefox3-

Comment 15

11 years ago
just had this happen on XP with 20080305 after rebooting before starting.
FF hung before dialog appear, 0% cpu. 
next startup attempt worked OK.  
(had just installed 20080305 after crashing FF trunk 20080204, and had rebooted several times as well to install some updates - crashed with no breakpad report)

anyone NOT seeing 0% cpu?
Severity: major → critical
Keywords: hang
Anyone experiencing this bug should attempt the steps here:
http://developer-cluster.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

I'm sure timeless wouldn't mind helping you get good results.

Comment 17

11 years ago
the regression range isn't the same, but might this be related to what's seen in bug 395891?

I don't startup but once every 3-4 weeks :) so I'm not likely to come across this again soon, if ever

Comment 18

11 years ago
yes, attach windbg, setup symbols as described, then at least run:
!analyze -v -hang
~* kp

then *attach* (don't paste) the output. Someone will grab the relevant portion and inline it into the bug later.
I have not seen this issue in quite some time now, so close as WFM ?
Closing WFM per comment above.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.