bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Zoom reverts to 100% when open link in new tab, disabling dom inspector solves the problem




Extension Compatibility
11 years ago
8 years ago


(Reporter: gtreutwein, Unassigned)


2.0 Branch
Windows XP

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [caused by dom inspector])



11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20070515 Firefox/
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20070515 Firefox/

If the zoom was in/decreased using the "+/-" keys and on one of the present links the context menu "open in new tab" is choosen, the tab open correctly, but the zoom level falls back to 100% in the current tab.

Reproducible: Always

Steps to Reproduce:
1.Increase zoom level (by + or via menu)
2.Right click on any link
3.Select "open as new tab"
Actual Results:  
New tab opens, zoom level of tab containing the link is back to 100 %.

Expected Results:  
Zoom level should definitively be unaffected for current level, one can argue, whether the level for the new tab should be the same one, or the 100% as it currently is.
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 108391
Hmm, indeed this doesn't sound like a duplicate of bug 108391.  Reopening.  The next step would be for someone to test for the presence of this bug on the trunk (i.e. the Firefox 3 nightly builds), since it looks like you've experienced it in Firefox 2, and there have been some changes to the behavior of text zoom on the trunk recently.
Resolution: DUPLICATE → ---

Comment 3

11 years ago
i cannot reproduce this in Branch or in Trunk...
reporter: do you still see that?

Comment 4

11 years ago
In Firefox the effect is still present

Comment 5

11 years ago
i still don't see this...

Is it there in Safe Mode too? (http://kb.mozillazine.org/Safe_Mode)
Could you also try with a new profile? (http://www.mozilla.org/support/firefox/profile#new)
Reporter, does this happen on every page?  Can you provide an example of a page on which it happens (and a specific link on the page that we should "open in new tab")?

Comment 7

11 years ago
Sorry, I had not noticed the safe mode stuff in the mail I received.
This is what I did: In safe mode (with only extensions disabled) it didn't occur.
Switching back to normal mode made it re-appeared.
I then tried to switch off each extension manually. The first extension was DomInspector. I disabled it, restarted firefox and - success!
I then re-enabled it and it still works.
While I don't understand it, its fine for me now.

Comment 8

11 years ago
moving to general (not a tab problem), probably someone could investigate on this dom inspector problem, i don't resolve for now
Component: Tabbed Browser → General
QA Contact: tabbed.browser → general
Summary: Zoom reverts to 100% when opening link as new tab → Zoom reverts to 100% when open link in new tab, disabling dom inspector solves the problem

Comment 9

9 years ago
I got the same bug. using NoSquint set to %120, but it'a actually %100 beause I can ctrl scroll up and it will go from 120 to 110, as in from %100 to %110 instead of %120 to %130. Aslo you can zoom in on a tab, view another tab and come back to the previous, and it will be back to %100

Comment 10

8 years ago
I have IIS 7 running because of .asp pages I am working with on my PC. I went into about:config and set zoom.minPercent to 125. If I load pages from the internet initially, the zoom is fine. If I load an .asp from my PC, the zoom reverts to 100 and so will internet pages after the .asp page. I tried setting browser.zoom.siteSpecific to T/F and that did not help. If I load the .asp page and click "View>Zoom In" once, the page will zoom larger than the 125. It would also be nice if the zoom option was similar to IE 8. Thanks...
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
Whiteboard: [CLOSEME 5-15-2010]
Version: unspecified → 2.0 Branch

Comment 12

8 years ago
I am running Firefox 3.6.3 and the bug is still present on Windows 7.
Roger, do you have dom inspector installed? This bug is INVALID as it is caused by DOM inspector. If you don't, please file a new bug that gives your results in a new profile
Last Resolved: 11 years ago8 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Resolution: --- → INVALID
Whiteboard: [CLOSEME 5-15-2010] → [caused by dom inspector]
You need to log in before you can comment on or make changes to this bug.