Email address in attribution line

VERIFIED FIXED in M17

Status

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: BenB, Assigned: BenB)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

19 years ago
Reproduce:
1. Reply
2. Look at the first line (the attribution line)

Actual result:
The From header of the original msg, usually "Author name <author email address>
wrote:" or "author email address (Author name) wrote:".

Expected result:
4.x behaviour:
- If there's an Author name use only this, i.e. "Author name wrote:".
- If the original from header contains only an email address, use this, enclosed
in angle brackets, i.e. "<author email address> wrote:" (this is new, i.e. 4.x
doesn't know this case)
- Otherwise, use the From header of the original msg as is, e.g. "anywierdfrom
wrote:"

Justification:
The email address is technical information, which shouldn't be in the msg text.

The special "angle-bracket-case" makes the email address less ambiguous
(recognition is easier).

Updated

19 years ago
Keywords: 4xp
QA Contact: lchiang → esther
Accepting
Severity: normal → enhancement
Status: NEW → ASSIGNED
Target Milestone: --- → M20
(Assignee)

Comment 2

19 years ago
Taking bug. Don't want NS6 to ship with this bug, or I'll be endlessly annoyed.
Assignee: ducarroz → mozilla
Status: ASSIGNED → NEW
Target Milestone: M20 → M17
(Assignee)

Comment 3

19 years ago
/
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Severity: enhancement → normal
(Assignee)

Comment 4

19 years ago
Looks like this was a bug by all means: The code was there, but didn't work. I
changed it a bit and it worked.

ducarroz, can you review please? See
<http://www.bucksch.org/1/projects/mozilla/review.html>.

(ducarroz, please also compare the changes from version 1.103 to 1.104
<http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/mailnews/compose/src&command=DIFF_FRAMESET&file=nsMsgCompose.cpp&rev2=1.104&rev1=1.103>.)
Keywords: patch, review
Whiteboard: Fixed
(Assignee)

Comment 5

19 years ago
I did unrelated changes for bug 29653 near the changes for this bug. I will
attach the patch to the other bug. Sorry.
Whiteboard: Fixed → Fixed. Patch in bug 29653.
(Assignee)

Comment 6

19 years ago
The changes to the other bug are checked in. Will attach the changes to for this
bug (only).
Whiteboard: Fixed. Patch in bug 29653. → Fixed.
(Assignee)

Comment 7

19 years ago
Created attachment 11051 [details] [diff] [review]
Fix, version 2
Looks good. R=ducarroz. Thanks Ben.
(Assignee)

Comment 9

19 years ago
Checked in. Tnx for review.
Whiteboard: Fixed.
(Assignee)

Comment 10

19 years ago
/
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Bug is somewhat fixed, but not exactly in the way Ben proposed:
When just the e-mail address (e.g. foo@bar.com) is in the from header we get now:
"foo@bar.com wrote:" and not "<foo@bar.com> wrote:"
=>not yet verifying
(Assignee)

Comment 12

18 years ago
Sebastian, good catch, I forgot this. The main problem is fixed however, and
making this enhancement might depend on the "verify wellformed-ness of email
address" bug, so I filed a bug 54844 about this.

Comment 13

18 years ago
ok, I'm happy now. :-)
veriying fixed with bug 54844 split off
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.