Session restore kicks in with -silent

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

BUILD:  Current trunk build

STEPS TO REPRODUCE
1)  Start Firefox
2)  Crash it (kill in Task Manager, kill -SEGV on Linux, whatever)
3)  Run "firefox -silent"

EXPECTED RESULTS:  No session restore dialog; dialog appears on first startup without -silent

ACTUAL RESULTS:  Dialog comes up with -silent

Comment 1

11 years ago
Pretty much a dupe of bug 365581 which I hope to actually fix in bug 354894.

Although to be clear: with "firefox -silent -browser" you'd still get the Session Restore prompt in the same way you'd also get the Set Default Browser prompt.
But without -browser it would actually be silent?

Comment 3

11 years ago
Yes, as long as you don't open any browser window, you should get no prompt at all.

Comment 4

10 years ago
Resolving as WORKSFORME since the Session Restore prompt was removed in bug
448976.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.