up/down arrow keys do not allow scrolling through entire list of drop-down bookmark entries

RESOLVED DUPLICATE of bug 382260

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 382260
11 years ago
11 years ago

People

(Reporter: Kenny Leong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

If a mouse cursor is first used to hover over an entry in a dropdown bookmarks list, then the immediate use of the down (or up) arrow keys will not allow the user to scroll through each and every entry in the entire bookmarks list. The scrolling sequence (while using the down or up) arrow keys) rolls over to the beginning (or end) of the bookmarks list when the highlighted bookmarks entry moves beyond the entries that are currently visible on-screen.

Reproducible: Always

Steps to Reproduce:
I notice a user interface issue relating to the bookmarks dropdown list. The problem occurs with firefox 2 and firefox 1.5, and it probably occurs in previous firefox versions too.

The issue can be observed when there is a fairly long list of bookmark entries, such as greater than 50 entries. I have more than 100 entries in my typical bookmark list.

To see the issue, I perform the following steps. (first, make sure the bookmarks list has a lot of entries, like 50 to 100 entries, or more).

1. Click on Bookmarks (in the File - Edit - View - History - Bookmarks menu bar). Here, the bookmarks list will drop down.

2. Use the mouse cursor to hover over any one of the bookmark entries. Here, entry that the cursor hovers over will become highlighted.

3. With that arbitrary bookmark entry highlighted, let go of the mouse and leave the mouse alone. Here, the entry will remain highlighted.

4. Use the down-arrow key, and keep using the down-arrow key (by pressing many times) to attempt to scroll through the entire list of bookmark entries. For example, if you have 100 entries in the entire bookmark list, then try to keep pressing the down-arrow key to step through the entire list of bookmark entries. 

The issue will become evident when one realizes that when the user uses the down-arrow key to step past the last entry that is currently on-screen in the bookmarks list, the scrolling sequence will not continue to the very next entry in the bookmark list. But instead, the scrolling sequence will roll back to the beginning of the bookmark list.
Actual Results:  
Using the down (or up) arrow keys to scroll through entire (long) list of bookmark entries in the dropdown list is not possible.

Expected Results:  
I expect the down (or up) arrow keys to be able to scroll through the entire list of bookmark entries in the dropdown list.

This is a fundamental handling error that should not be there.
(Reporter)

Comment 1

11 years ago
I forgot to add that, when the up-arrow key is used under the conditions described above, then a similar thing happens. What happens is that when one attempts to use the up-arrow key to scroll upwards past the top-most visible on-screen entry, then the scrolling sequence will rollover to the very last entry in the bookmark list (instead of just continuing upward through the list).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382260
You need to log in before you can comment on or make changes to this bug.