form fields misaligned with certain font sizes

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
minor
VERIFIED FIXED
11 years ago
2 years ago

People

(Reporter: clouserw, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 268957 [details]
screenshot of the brokenness

(from an email that Nukeador sent l10n-web)

In the AMO login page
(https://addons.mozilla.org/es-ES/firefox/users/login) there is a
problem when the <label> text and font style became too big and they
overflow the parent div, the design messes up because the next <label>
has float: left. This happens for example in es-ES version (some Firefox
under linux).

------------------------------------------------------------------
Direcci�n de correo      [______________]
electr�nico
                        Contrase�a              [___________]
------------------------------------------------------------------



In order to solve this issue, we could do two different things.
Force divs inside the form to be positioned below the floating elements,
adding something like this:
.amo-form div {
   clear:both;
}

Or stretching the divs with the classic clearfix:
|.clearfix:after {content: "."; display:block; height:0; clear:both;
visibility:hidden;}
.clearfix {display:inline-block;}
/* Hides from IE-mac \*/ * html .clearfix {display:block;} /* End hide
from IE-mac */|

Updated

11 years ago
Component: Add-ons → Public Pages
QA Contact: add-ons → web-ui
Version: unspecified → 3.0

Comment 1

10 years ago
Seems like https://addons.mozilla.org/es-ES/firefox/users/login is fixed. Please re-open if it's a problem.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified FIXED for me too; zoomed in, changed font size to 24 from 16, and still can't reproduce.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.