Width of event shrinks in week view when it does not need to

VERIFIED DUPLICATE of bug 304741

Status

Calendar
Calendar Views
--
enhancement
VERIFIED DUPLICATE of bug 304741
11 years ago
11 years ago

People

(Reporter: Crystle Numan, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.2) Gecko/20070220 Firefox/2.0.0.2
Build Identifier: Sunbird 0.5

In week view, when a time of day has multiple events, the width of each shrinks. Subsequent events (outside of these times) are also shrunk to the same size, even if their time does not overlap.

This makes these events difficult to read, when they do not need to be.

Reproducible: Always

Steps to Reproduce:
1. (In week view) Add three events around the same time in a day. They will take up 1/3 of the width of the day.
2. Add an event that starts after all three of the others end. It will still only take up 1/3 width of the day
3.
Actual Results:  
Event only takes up the same size as the other events of the day, even if there is overlap.

Expected Results:  
The event should be the fullest width it can be at that time. A further enhancement would have the event actually overlap the other even, perhaps with the longer one full width, and the shorter one half width on top. (Google calendar does something like this that might have some merit)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 304741

Updated

11 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

11 years ago
Sorry, I searched but couldn't find the other one. Thanks for connecting the two.
You need to log in before you can comment on or make changes to this bug.