Download manager doesn't save files to VFAT partition

RESOLVED DUPLICATE of bug 374789

Status

()

--
major
RESOLVED DUPLICATE of bug 374789
12 years ago
10 years ago

People

(Reporter: blueser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070603 Fedora/2.0.0.4-2.fc7 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070603 Fedora/2.0.0.4-2.fc7 Firefox/2.0.0.4

I have a VFAT partition on my dual-boot system at home. My main storage area for temporary files (images, movies etc.) is located on this partition. For a while already I have been unable to download any kind of files (eg. GMail attachments) -- a target file is created with 0 bytes, and nothing else happens.

I thought this could be caused by one of my extensions, but today I bit the bullet and disabled them one by one. No luck.

I created a new profile (no extensions installed) and confirmed that downloads worked as expected. Then I realized what was different: by default, download dir on new profiles is ~/Desktop, which is not VFAT. I then set the download dir to be the same dir on the VFAT partition, and the same wrong behavior surfaced once again.

To put the nail on the coffin, I switched back to my profile and set the download dir to ~/Desktop, and downloads started working again as expected.

Reproducible: Always

Steps to Reproduce:
1.set download dir to a VFAT partition
2.start a download and choose "save to disk"
3.
Actual Results:  
file is created with 0 bytes, and download stops without any error messages

Expected Results:  
all bytes should have been downloaded, or at least an error message should have been shown
(Reporter)

Comment 1

12 years ago
Target VFAT partition is almost full, but still has enough storage area (780M) to hold the files I am trying to download:

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda6              54G   54G  780M  99% /windata

/dev/sda6 on /windata type vfat (rw,nosuid,nodev,uid=500,gid=100)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 374789
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.