Autocomplete suggestions list while typing in "To:" recipients does not disappear when using TAB to quickly move focus to subject field

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
5 years ago

People

(Reporter: alex, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.8.1.4) Gecko/20070602 Firefox/2.0.0.4
Build Identifier: version 2.0.0.0 (20070514)

Most times (not always reproduceable) when I start Thunderbird and click "compose", then enter part of the name (Stua instead of Stuart for example), the name completes, but there are still other choices in the list box below. I then click TAB, enter subject, click TAB, enter message, but the list box of the possible To completions stays and doesn't go away. Sometimes even after I sent the message - still have the listbox on my screen. I have to click on it and select something from it using a mouse to make it go away.

Reproducible: Sometimes

Steps to Reproduce:
1. Start Thunderbird
2. Click Compose
3. Enter part of name of receipient
4. TAB to move to subject, leaving the list box of possible completions there and the requried name completely completed
5. Type subject, TAB to go to body, carry on.
Actual Results:  
The listbox of possible completions stays.

Expected Results:  
The listbox goes away, since the name was completed already.

I think I am using all the defaults that come with Thunderbird on NetBSD.

Here is a useful screenshot:

http://www.mcs.vuw.ac.nz/~alex/bugs/thunderbirdkdebug.png

Cheers,
Alex.

Comment 1

11 years ago
Tag choses one of the auto complete suggestions for me, so I never get into that situation.

Comment 2

7 years ago
I can reproduce this. you must tab quickly, before before the autocomplete can finish.

perhaps a duplicate?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [dupeme?]

Comment 3

7 years ago
Created attachment 564678 [details]
screen shot of results
Wayne, still reproducible as you did in comment 3?
Flags: needinfo?(vseerror)
Summary: Possible completions of "To" do not disappear after the focus gone away from the "To" box → Autocomplete suggestions list while typing in "To:" recipients does not disappear when using TAB to quickly move focus to subject field

Comment 5

5 years ago
I dont recall seeing this recently
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(vseerror)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.