impl platform-specific code for find protocol/content-handling local apps

RESOLVED DUPLICATE of bug 400852

Status

--
enhancement
RESOLVED DUPLICATE of bug 400852
12 years ago
2 years ago

People

(Reporter: dmose, Unassigned)

Tracking

unspecified
mozilla1.9alpha8

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
There may be some platform-specific code that needs to be written to get the list of apps that is registered to handle a MIME-type or a content-type locally so that they can be offered as options to the user.  beltzner, faaborg: should we be shooting to list all apps that are registered as knowing how to handle a specific content type, or just the default?
Flags: blocking1.9?
(Reporter)

Updated

12 years ago
Flags: blocking1.9?
Target Milestone: mozilla1.9alpha6 → mozilla1.9beta1
(Reporter)

Comment 1

11 years ago
The basics of this code already exist and are in the tree, which is to say that we can get at least one handler for a given protocol or MIME-type on any platform if it exists.  I assert this is sufficient for Firefox3.  Windows is improving its support for more apps in the MIME-type case in bug 348808.  

I suspect that at some point, the Mac and Linux code could be changed to do something similar, and probably want to be updated to newer system-level APIs.
This doesn't actually block Bug 372441
No longer blocks: 372441
(Reporter)

Comment 3

11 years ago
Bug 400852 covers this for windows, and there are other bugs open for application picker support on other platforms.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400852
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.