Events on RSCDS CalDAV server are not visible

RESOLVED WORKSFORME

Status

Calendar
Provider: CalDAV
--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: IJsbrand Oudshoorn, Unassigned)

Tracking

Lightning 0.5
x86
Windows XP

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.1.4pre) Gecko/20070614 Sunbird/0.5 and Lightning 0.5 (rc1 and rc2) in Thunderbird 2.0.0.4 (20070604)

This might be a duplicate of bug 373439, but with the new 0.5 versions.

My configuration:
Server is RSCDS (Really Simple CalDAV Server) (I've tried both version 0.6 and 0.8) on Linux Suse 10.1.
Client is Lightning 0.5 on Thunderbird 2.0.0.4 or Sunbird 0.5 on Windows XP Professional SP 2.

With the Lightning 0.3.1 everything works just fine.
With the Lightning and Sunbird 0.5 rc1 and rc2 the events does not appear in the calendar view. (Not in day, week or month view).
I've tried both localizations nl and en-US.
Uninstalling 0.5 and installing 0.3.1 works.

On a fresh configuration (a complete different client with same specification) I get the same behaviour as George describes in bug 373439. Thus on the first time setting the calendar (http://myserver/cal/caldav.php/MyCalendar/home/) every thing works till I restart Thunderbird or Sunbird. After the restart there is no possibility to get the events visible anymore (removing and adding the calender does not help).

I've tried to use local calendars, that works fine as long as there are only local calendars in the list. If there is one remote CalDAV calendar in the list the events on the local calendars disappear after switching view. (Thus from month to week or v.v.). This behaviour looks like bug 382811.

Please let me know if you need more specific information. If needed I can create a remote accessible calendar on my server for testing purpose.

Reproducible: Always

Steps to Reproduce:
1. Install Lightning 0.5
2. Add a remote calendar that is located on a RSCDS CalDAV server.
3. Restart Thunderbird.
Actual Results:  
No events visible.


The Errorconsole is in the most cases empty. After some working/clicking around I finally got some logs. The first log seems the most important. But as I said, it works with version 0.3.1.

Fout: [Exception... "'The resource at http://eitriserver/caldav.php/IJsbrandCalendar/home/ is either not DAV or not available
' when calling method: [nsIWebDAVOperationListener::onOperationComplete]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "<unknown>"  data: no]

Fout: geen element gevonden
Bronbestand: http://extensions.hesslow.se/update.php?id={8845e3b3-e8fb-40e2-95e9-ec40294818c4}
Regel: 1, Kolom: 1
Broncode:
^

Fout: gMsgFolderSelected has no properties
Bronbestand: chrome://messenger/content/msgMail3PaneWindow.js
Regel: 226

Updated

11 years ago
Component: Calendar Views → Provider: CalDav
QA Contact: views → caldav-provider
(Reporter)

Comment 1

11 years ago
I'VE FOUND THE SOLUTION

First of all the first error in the Error Console mention above was a typo,
BUT was not the source of this problem.

On the server I've added a symbolic link.
/etc/rscds/localhost-conf.php -> /etc/rscds/eitriserver-conf.php

Where eitriserver is the name of my server, and eitriserver-conf.php is my existing configuration file.

I'm quite sure that this was the source. I've removed the localhost link to reproduce this problem.

Keeps still some open points:
1. It is still strange that the 0.3.1 version works fine with this miss-setting.
2. A message box noting that the DAV server isn't found is a nice enhancement. It will prevent simple typo's.
Version: unspecified → Lightning 0.5

Comment 2

11 years ago
Resolving WORKSFORME per Comment #1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.