various Mac OS X builds failing to compile

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
8 months ago

People

(Reporter: jaas, Assigned: benjamin)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
Created attachment 269081 [details]
build error output 1

Various trunk Mac OS X builds are failing to compile. I can't get any debug builds to work, and one opt Camino tbox is failing with the same error.

/usr/bin/ld: Undefined symbols:
_FSGetParentRef
_FSRefValid
(Reporter)

Comment 1

12 years ago
Created attachment 269082 [details]
more build error output
Attachment #269081 - Attachment is obsolete: true
Same issue on 
  MacOSX Darwin 8.8.4 bm-xserve11 Dep Debug + Leak Test %
which is new on the MozillaTest tbox tree.
(Reporter)

Comment 3

12 years ago
Note that those symbols are not OS symbols - they are from MoreFilesX which is in xpcom.
(Assignee)

Comment 4

12 years ago
Created attachment 269083 [details] [diff] [review]
put macmorefiles into libreg, rev. 1
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #269083 - Flags: review?(joshmoz)

Updated

12 years ago
Attachment #269083 - Flags: review?(joshmoz) → review+
(Assignee)

Updated

12 years ago
Duplicate of this bug: 385109
(Assignee)

Comment 6

12 years ago
Fixed on trunk with one additional change to xpcom/build/Makefile.in to get libxul working correctly again.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.