Make version entry a text field instead of a pulldown

RESOLVED DUPLICATE of bug 287328

Status

()

Bugzilla
Bugzilla-General
P3
enhancement
RESOLVED DUPLICATE of bug 287328
18 years ago
12 years ago

People

(Reporter: CodeMachine, Assigned: Nobody's working on this, feel free to take it)

Tracking

Details

(Reporter)

Description

18 years ago
The current version field on mozilla.org is not used at all.  There are just too
many versions possible.  It would be better if it was a text field.
(Reporter)

Comment 1

17 years ago
Moving to BZ3.0, Hixie, this should be quite possible out of all the field
modularity stuff.

This would likely be a good idea for Mozilla as a Build-ID, and we would want to
keep Bugzilla the same.
Assignee: tara → ian
Component: Bugzilla → Bugzilla 3
QA Contact: matty → ian
Target Milestone: --- → Bugzilla 3.0
(Reporter)

Comment 2

17 years ago
Taking QA.
QA Contact: ian → matty
The Bugzilla 3 component is going away.  We're going to depend on the Milestones 
for this.  At the time this component was created, we didn't have milestones for 
Bugzilla.
Component: Bugzilla 3 → Bugzilla
Severity: minor → enhancement
Summary: Version field next to useless. → Make version entry a text field instead of a pulldown
(Reporter)

Comment 4

17 years ago
Text field should be able to have a regexp enforced.

Should be able to have a text field for one product and a options field for
another.

Can't be the same column in a table because text would be text and options would
by an option id (so options can be renamed).
(Reporter)

Updated

17 years ago
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
Bailing on Bugzilla 3.0 due to too many other commitments.
Assignee: ian → nobody

Updated

13 years ago
Assignee: nobody → nobody

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 6

12 years ago
This would be better implemented as a custom field.

*** This bug has been marked as a duplicate of 287328 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 3.0 → ---
You need to log in before you can comment on or make changes to this bug.