Closed Bug 385292 Opened 16 years ago Closed 16 years ago

Enter (to submit form) appears to delete the selection

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.9beta1

People

(Reporter: jruderman, Assigned: masayuki)

References

Details

(Keywords: regression)

Attachments

(2 files)

Steps to reproduce:
1. Load http://www.google.com/
2. Type "foobar".
3. Select "bar".
4. Press Enter.

Result: "bar" disappears, leaving "foo", and the form is submitted (as foobar, luckily).
Flags: blocking1.9?
Looks like this works on Win32, Josh, could this be related to any Mac widget changes or something like that?
Assignee: nobody → joshmoz
Component: HTML: Form Submission → Widget
Component: Widget → Widget: Cocoa
Flags: blocking1.9? → blocking1.9+
QA Contact: form-submission → cocoa
Can we find a regression window?
Target Milestone: --- → mozilla1.9 M9
Masayuki - it looks like we're sending the enter as a text entry command instead of bailing after gecko handles the key down or press event to submit the form. I think you'd know more about fixing this than me, can you take a look?
Assignee: joshmoz → masayuki
Status: NEW → ASSIGNED
Attached patch Patch rv1.0Splinter Review
This patch also fixes bug 396808.

The editor event listener uses keyCode of key press event for filtering. But cocoa widget is not setting it at generating the events.
Attachment #283824 - Flags: review?(joshmoz)
Comment on attachment 283824 [details] [diff] [review]
Patch rv1.0

+  NS_WARNING("GetGeckoKeyCodeFromChar is failed.");

You can either not have the "is" there or change it to "has".

Thanks for doing this!
Attachment #283824 - Flags: superreview?(roc)
Attachment #283824 - Flags: review?(joshmoz)
Attachment #283824 - Flags: review+
Attachment #283824 - Flags: superreview?(roc)
Attachment #283824 - Flags: superreview+
Attachment #283824 - Flags: approval1.9+
checked-in.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Depends on: 399485
This appears to have caused bug 399740.
Depends on: 400355
This has also caused bug 401425.
Depends on: 401425
You need to log in before you can comment on or make changes to this bug.