Closed Bug 385347 Opened 13 years ago Closed 4 years ago

when I mouse over certain .dlls, I get a tooltip claiming the company is "Netscape Communications Corporation"

Categories

(Core :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: moco, Assigned: wtc)

References

Details

Attachments

(3 files)

when I mouse over certain .dlls, I get a tooltip claiming the company is "Netscape Communications Corporation"

/js/jsd/jsd3240.rc, line 77 -- VALUE "FileDescription", "Netscape 32-bit JavaScript Debugger Module\0"
/js/src/js3240.rc, line 38 -- VALUE "FileDescription", "Netscape 32-bit JavaScript Module\0"

wtc:  It looks like nspr4.dll and plc4.dll and plds4.dll do the same thing.

bsmedberg:  for xul.dll, I don't see any company info at all.

For the rest of the dlls, I see "Mozilla Foundation"
We fixed this bug for the NSS DLLs in bug 326403.  Somehow we
forgot to fix the NSPR and JSS DLLs.

Our fix was to change "CompanyName" to "Mozilla Foundation\0"
and remove the optional "LegalCopyright".
Attached patch NSPR patchSplinter Review
Seth, could you review and test this patch for NSPR?  Thanks.
Attachment #269405 - Flags: review?(sspitzer)
Attached patch JSS patchSplinter Review
Glen, please review and test this patch for JSS.  Thanks.
Attachment #269409 - Flags: review?(glen.beasley)
> bsmedberg:  for xul.dll, I don't see any company info at all.

spun off to bug #385496
Product: Firefox → Core
QA Contact: general → general
Comment on attachment 269409 [details] [diff] [review]
JSS patch

 cvs commit -m "385347 CompanyName shoud be Mozilla Foundation fix=wtc r=glen" jss.rc
Enter passphrase for key '/Users/b/.ssh/id_dsa': 
Checking in jss.rc;
/cvsroot/mozilla/security/jss/lib/jss.rc,v  <--  jss.rc
new revision: 1.3; previous revision: 1.2
done
Attachment #269409 - Flags: review?(glen.beasley) → review+
Comment on attachment 269405 [details] [diff] [review]
NSPR patch

r=sspitzer, sorry for the long delay Wan-Teh.

I've reviewed and tested against the firefox trunk.
Attachment #269405 - Flags: review?(sspitzer) → review+
Comment on attachment 269405 [details] [diff] [review]
NSPR patch

Thanks.  I checked in the NSPR patch on the NSPR trunk for NSPR 4.7.

Seth, others still need to fix the js3250.dll and xul.dll issues.
Duplicate of this bug: 369817
Js is covered by 341901
xul is covered by 387454
Assignee: nobody → wtc
I'm fixing mozcrt19.dll in bug 415918.
Currently no longer exists.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.