Changes to the Action or Expected Results section of Test Cases cause incorrect or duplicate search results

RESOLVED DUPLICATE of bug 437132

Status

Testopia
Search
RESOLVED DUPLICATE of bug 437132
11 years ago
10 years ago

People

(Reporter: Costa Galanis, Assigned: Greg Hendricks)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 1.2

It appears that the Test Case search tool is searching through old versions of Test Cases. When a change is committed to the Action or Expected Results section, the old Case Versions do not seem to be skipped by the search.

For instance, let's say that originally my Expected Results section for a test case has the sentence "The user is loggged in" (notice the typo in the word logged), and I make a commit to correct the typo. Now, I do a search that looks for the word "user" in the Expected Results section. In this case, the test case is returned twice in the results. If I make another change and then repeat the search, I will get it three times.

The symptom described above is not so bad, since the results are still accurate if you just ignore the duplicate rows. Moreover, Bug 384212 can actually be used as a temporary workaround for this :P. However, there is another more serious symptom that leads to inaccurate results and that I have not found any workaround for. Let's say for instance for instance that the Expected Results field originally reads as follows "The server is logged in" where the word "server" was a mistake and should have been "user". I notice the mistake and correct it by changing the word "server" for "user" and committing the change. Now, if I do a TC search for the word "server" in the Expected Results section, the Test Case I fixed should not be returned, because the word has been removed. Due to this bug however, the test case will incorrectly be returned because the word used to be there in an old version.

Reproducible: Always

Steps to Reproduce:
1. Create a Test Case where the Action section is simply the following: "Apple Banana"
2. After the TC has been created, go back to it and delete the word "Banana" and commit the change.
3. Go to the Test Case Search page and look for the word "Apple" in the Action section.
4. Try again with the word "Banana"
Actual Results:  
3. The test case is returned twice in the search results.
4. The test case is returned in the results.

Expected Results:  
3. The test case is returned once in the search results because it still contains the word "Apple" in the Action section.
4. The test case is not returned because the word "Banana" is no longer in the Action section.

This makes creating batches of similar test cases with only a small change in them using the Clone feature a painful situation when it comes to searching through them later on. If I clone a test case 5 times and change one section each time, but then do a search for a term in the original section that was changed for all the rest, all 6 test cases are returned.

I have not checked if this is also reproducible for the Test Plan Document, which also uses the same WYSIWYG-type editor to create the Document section, but I assume it would also be reproducible there.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437132
You need to log in before you can comment on or make changes to this bug.