Closed Bug 385541 Opened 14 years ago Closed 14 years ago

Make use of various List-* headers (RFC2369)

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 29041

People

(Reporter: bugzilla, Assigned: Bienvenu)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 

Request for enhancement:

Many mailing lists have the following message headers:
List-Unsubscribe: <https://www.redhat.com/mailman/listinfo/fedora-list>,
	<mailto:fedora-list-request@redhat.com?subject=unsubscribe>
List-Archive: <https://www.redhat.com/archives/fedora-list>
List-Post: <mailto:fedora-list@redhat.com>

It would be very cool/helpful if these were made into "buttons" when viewing a message.

Perhaps to the right of where other headers (Subject, Date, To etc) are displayed, a couple of buttons could be available:

Compose new message to list
(This may cut down on thread-hijacking)

View list archives (which will then open the web browser)

Unsubscribe
If there is a mailto: tag use that, or when List-Unsubscribe is a list of choices, perhaps make a dropdown list of choices..


Reproducible: Always

Steps to Reproduce:
1. This is not a bug, it's an enhancement request
2.
3.
yes, that's a nice idea to use buttons when viewing a message.
Assignee: nobody → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
See also bug 29041 (and the cloud around it), which has traditionally and incorrectly been used as an all-products version of this, even though it's pretty clearly front-end rather than shared compose code.
OS: Windows XP → All
Hardware: PC → All
Summary: Make use of various List-* headers → Make use of various List-* headers (RFC2369)
Marking as dupe for now since much of the work should be backend.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 29041
You need to log in before you can comment on or make changes to this bug.