If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash, when Bookmark Properties is opened

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Hiro, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

27.63 KB, text/plain
Details
(Reporter)

Description

10 years ago
Reproducible: Always

Steps to Reproduce:
1. The bookmark is selected with Bookmark Manager and Edit -> Properties is chosen. 
    Or, it right-clicks in bookmarks of Bookmark Toolbar, and Properties is chosen from context menu. 


Crash ID: bp-6628a6d7-2172-11dc-8fe7-001a4bd43ed6

Mac OS X 10.3.9
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a6pre) Gecko/20070623 Minefield/3.0a6pre
(Reporter)

Comment 1

10 years ago
Created attachment 269504 [details]
crash log

Crash log of OS was obtained by the following commands. 

defaults write org.mozilla.firefox OSCrashReporter -bool true
From the stack, it looks like a thebes issue:
Thread 0 Crashed:
0   libobjc.A.dylib          	0x919501f4 objc_msgSend + 0x14
1   XUL                      	0x2d82eccc nsChildView::GetThebesSurface() + 0x549c
2   com.apple.Foundation     	0x90a4afb0 __NSFireMainThreadPerform + 0x108
3   com.apple.CoreFoundation 	0x902151b0 __CFRunLoopPerformPerform + 0x88
4   com.apple.CoreFoundation 	0x901c4800 __CFRunLoopDoSources0 + 0x1fc
5   com.apple.CoreFoundation 	0x901c20b8 __CFRunLoopRun + 0x1b0
6   com.apple.CoreFoundation 	0x901c69e4 CFRunLoopRunSpecific + 0x148
7   com.apple.HIToolbox      	0x92886e10 RunCurrentEventLoopInMode + 0xac
8   com.apple.HIToolbox      	0x9288d4b4 ReceiveNextEventCommon + 0xf4
9   com.apple.HIToolbox      	0x928af638 BlockUntilNextEventMatchingListInMode + 0x60
10  com.apple.AppKit         	0x92e82248 _DPSNextEvent + 0x180
11  com.apple.AppKit         	0x92e98cc8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 0x74
12  XUL                      	0x2d82330c nsAppShell::ProcessNextNativeEvent(int) + 0xc8
13  XUL                      	0x2d8389fc nsBaseAppShell::DoProcessNextNativeEvent(int) + 0x30
etc.
Component: Bookmarks → GFX: Thebes
Product: Firefox → Core
QA Contact: bookmarks → thebes
Hiro, please update to the latest beta release of Firefox 3 and try again. Is this crash still valid for you?
Severity: normal → critical
Keywords: crash

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.