Simplify the Quit dialog when the session will be resumed anyway (don't omit it)

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
11 years ago
7 years ago

People

(Reporter: Simon Bünzli, Unassigned)

Tracking

unspecified
Firefox 3 beta3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
As per bug 341248 comment #6, the Quit dialog should not be omitted when the session will be resumed. It should however be simplified to only show two buttons: "(Save and) Quit" and "Cancel" (the last button does the same as the first in this situation).

Of course we could also try to implement some heuristics to determine whether anything would be lost by closing the application - but I'm not sure how hard it would be to get this only half-way right.

Comment 1

11 years ago
> Simplify the Quit dialog when the session will be resumed

Isn't the entire point of having both buttons in the Quit dialog to let you decide while quitting whether the session will be resumed?  What do you mean by "when the session will be resumed"?
(Reporter)

Comment 2

11 years ago
Currently there's no dialog at all when browser.startup.page == 3 and browser.tabs.warnOnQuit == true. As per bug 341248 there should be one - however since the session will be resumed anyway, having two different quit buttons which do exactly the same doesn't make sense.

Of course one alternative would be to let the Quit dialog cancel session resuming (i.e. the options being "Discard Tabs and Quit", "Quit" (and resume as configured) and "Cancel") when browser.startup.page == 3.

Another alternative would be to show the Close Tabs prompt instead (which also offers a two button choice), although if .warnOnClose and .warnOnQuit should remain differently, browser.tabs.warnOnQuit should be used to decide whether to show that prompt in this case (so that the distinction between potential complete dataloss vs partial dataloss remains).
Summary: Simplify the Quit dialog when the session will be resumed (don't omit it) → Simplify the Quit dialog when the session will be resumed anyway (don't omit it)

Updated

11 years ago
Depends on: 383760

Updated

11 years ago
Flags: blocking-firefox3+

Updated

11 years ago
Target Milestone: --- → Firefox 3 M8

Updated

11 years ago
Assignee: nobody → flamingice
moving to M9, Michael, if you don't have cycles to fix this, please let me know.
Target Milestone: Firefox 3 M8 → Firefox 3 M9
moving out bugs that don't need to block b1
Target Milestone: Firefox 3 M9 → Firefox 3 M10

Updated

10 years ago
Target Milestone: Firefox 3 M10 → Firefox 3 M11

Comment 5

10 years ago
I find the current behavior pleasing, on Windows and Linux at least. If I'm closing a window and get the "closing multiple tabs" warning, I don't even read it, because I already know that it means that window won't be restored. Depending on whether I wanted to quit the app or really close the window, I can hit enter or escape. An additional, simplified (yet similar) quit dialog would make my life harder, as I would have to take a close look every time I close a window.

Updated

10 years ago
Priority: -- → P5
We're going to WONTFIX this for now, but we're reviewing all of the quit interactions to make sure they're optimal.
Flags: blocking-firefox3+
Priority: P5 → --

Updated

10 years ago
Target Milestone: Firefox 3 Mx → Firefox 3 M11
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

10 years ago
Gavin: What about the "simplify the Quit dialog" part of this bug? With Firefox set to "show my windows and tabs", I now get the options to either "Save and Quit" or just "Quit" at shutdown, where both do _exactly the same_. That's surely nothing to fix before RC1 but a bit of polish for Firefox.next, nonetheless... ?
Sure, seems reasonable to me.

(I just WONTFIXed this because mconnor said he was going to 5 months ago, and this bug has been loaded in a tab ever since, and just today I stumbled onto it and decided I should do something to get rid of it.)
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Updated

10 years ago
Duplicate of this bug: 456508

Updated

8 years ago
Assignee: mwu → nobody

Comment 10

7 years ago
invalid due to Bug 592822?
Just going to WONTFIX it. The quit dialog still exists, but just isn't shown by default. I think having another variation of a non-default dialog is just bad news bears.

If somebody still wants this, it's up to an addon.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.