Bookmark toolbar folders provide no feedback nor spring-open for bookmark d-n-d

RESOLVED DUPLICATE of bug 337761

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 337761
11 years ago
11 years ago

People

(Reporter: John Whitley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a6pre) Gecko/20070623 Minefield/3.0a6pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a6pre) Gecko/20070623 Minefield/3.0a6pre

Bookmark toolbar folders in Minefield 3.0a6pre provide no drag and drop feedback, nor do they spring open to allow positioned filing of bookmarks in the toolbar's folders.  Both of these features have been available on Windows for many versions (probably since FF 1.0, definitely 1.5).

This is related to bug 235243 for d-n-d feedback for bookmark toolbars, which made good strides but did not quite bring the usability of bookmark toolbars in Firefox on OS X into parity with the Windows implementation.


Reproducible: Always

Steps to Reproduce:
1. Drag the location bar favicon over a folder in the bookmarks toolbar.

Actual Results:  
No visual feedback is provided, the toolbar folder remains closed.

Expected Results:  
When the dragged bookmark is over a folder, as opposed to between items, visual feedback should be provided to indicate that the bookmark will land in the folder.  On Windows in FF 2.0, this is accomplished by opening the folder and changing the toolbar icon to an "open" folder.  Having the folder spring open to allow manual placement of the bookmark within is a vital part of the overall functional behavior.

The expected behavior described above is more-or-less analogous with the Firefox Windows behavior for some versions now.

On the Minefield build used for this test, I note that after the drag ends, and whether it ends on the toolbar or not, some portion of the bookmark toolbar that was dragged over "flickers".  I've observed two specific such effects: a folder flashes open then closed very rapidly, or else the new-to-3.0 dnd indicator flashes between folders.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 337761
You need to log in before you can comment on or make changes to this bug.