after hibernate firefox can't retrieve pages

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: alan.grover, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

I close all my applications (including Firefox) before hibernating, but when I come back from hibernation and start Firefox, it times out retrieving all pages.

I verified that I could ping the servers from which I was trying to download pages, and then started Internet Explorer to see if it also had the problem.  It correctly retrieved pages.  I then tried starting firefox again, and it correctly retrieved pages.


Reproducible: Always

Steps to Reproduce:
1. Close all applications and hibernate
2. Resume from hibernate
3. Start Firefox, try to retrieve google.com
4. Firefox times out
5. Ping google.com
6. Close Firefox (not sure this is necessary)
7. Launch IE, try to retrieve google.com
8. Launch Firefox again, try again.
Actual Results:  
Firefox would not retrieve google.com until after I had used IE

Expected Results:  
Firefox shouldn't depend on IE.  :)

Comment 1

11 years ago
Alan, 

Did you have the problem when you were using FF version 1.5?

Check Delay_or_hang_waking_from_standby at http://kb.mozillazine.org/Flash#Delay_or_hang_waking_from_standby

please report back your results.
Severity: normal → critical
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

11 years ago
No.  I never ran into it while using v 1.5.  My machine at that time would not hibernate correctly.
(Reporter)

Comment 3

11 years ago
Regarding the Delay_or_hang_waking_from_standby link, note that it says

"As a workaround, close the browser before placing the computer in standby/hibernation."

I am closing the browser before placing the computer in hibernation.

I also don't experience the other symptoms (high CPU usage, or the browser hanging) mentioned.

It simply times out trying to retrieve the requested page.

Comment 4

11 years ago
In the last two days I read a bug that (iirc recently) patched something in this area on trunk for MAC.  I can't find it to save my soul, but I suggest you try a trunk build briefly to see if it's gone. http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 5

11 years ago
seems to be fixed in 2.0.0.9
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 6

11 years ago
We don't know what fixed this WFM.
Resolution: FIXED → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.