Menus are transparent to many mouse events (was: When I click a bookmark in a toolbar folder, a different bookmark opens)

RESOLVED WORKSFORME

Status

()

Core
Event Handling
--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({dogfood, regression})

Trunk
x86
Mac OS X
dogfood, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Steps to reproduce:
1. Make sure your bookmarks toolbar contains a folder with 3+ items.
2. Make sure you have multiple tabs open.
3. Click the folder.
4. Slowly move the cursor down to the third item.
5. Click the third item.

Result: the second item opens.  (Also notice that the hovered-menu-item highlighting goes away as soon as you cross the bottom of the tab strip that's underneath the menu.)
Flags: blocking-firefox3?
(Reporter)

Comment 1

11 years ago
This seems to be a general bug with "popup menus".  I see cursors acting as if <select> dropdowns and the address bar autocomplete dropdown are transparent to mouse events.  For example, if I click the <select> on http://www.squarefree.com/start/ and move the cursor around inside it, the cursor changes into a "hand" when it's over part of the menu that covers a link.
Component: Places → Event Handling
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: places → events
(Reporter)

Updated

11 years ago
Flags: blocking1.9?
Summary: When I click a bookmark in a toolbar folder, a different bookmark opens → Menus are transparent to many mouse events (was: When I click a bookmark in a toolbar folder, a different bookmark opens)

Comment 2

11 years ago
Is this a mac only? Linux works fine.
Reminds me a bit of bug 291507. That one was fixed by bug 297561. Maybe useful to know.
(Reporter)

Comment 4

11 years ago
WFM.  I can't reproduce this in 2007-06-17, 2007- 06-24, 2007- 06-29, or a more recent debug build.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking1.9?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.