"Start the week on" is not restored properly when change localization

VERIFIED INVALID

Status

Calendar
Preferences
--
minor
VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: Damian Szczepanik, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.4pre) Gecko/20070614 Sunbird/0.5

In Options "Start the week on" is detected properly so when I create new profile the first day (Poland) is Monday but when I change localization to en-US Sunbird does not restore this field and I have Sunday instead of Monday

The problem is that if this dropdown list is not changed data is not stored and next time Sunbird again tries to guess the first day of week. When this list is changed then it works with different localizations.

Reproducible: Always

Steps to Reproduce:
(maybe OS settings matter, I'm from Poland)
1. launch Sunbird, use Polish build, eg sunbird-0.5.pl.win32.zip
2. Go to Options/Views
   -> "Start the week on" is set to Monday, if not try to change your OS setting because you can not change this dropdown list
3. launch Sunbird, use English build sunbird-0.5.en-US.win32.zip
Actual Results:  
First day is Sunday, not Monday as it was with Polish localization

Expected Results:  
I did not change the first day when Polish localization was running so it means that it was fine for me and I expect that Monday will be also the first day with other localizations.
This value should be saved when clean profile is inited.
Seems to be the same misunderstanding as in Bug 373699. 

The default value for "Start the week on" is not detected from system. It is specified in the file sunbird-l10n.js by the localization team. If you do not manually change the preference the default value is always used. If you now install a different locale sunbird-l10n.js is replaced and the default preference will be set to the value the localization team choose for this locale.

-> You have to manually set the preference to the value you want. In this case it will be saved in your profile.
Whiteboard: [qa discussion needed]

Comment 2

11 years ago
Since this seems to be a misunderstanding and not a bug, marking as INVALID
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Whiteboard: [qa discussion needed]
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.