Let you access multiple channels with one URL

RESOLVED WONTFIX

Status

Other Applications
ChatZilla
--
enhancement
RESOLVED WONTFIX
11 years ago
10 years ago

People

(Reporter: None, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 

ChatZilla should let you access multiple channels with one URL.

Reproducible: Always

Steps to Reproduce:
Not relevant
Actual Results:  
Not relevant

Expected Results:  
Not relevant

Comment 1

11 years ago
1) Why?

2) What would the syntax be like?

3) Do other clients support this at all?

Comment 2

11 years ago
I think that the IRC scheme is already overloaded to the point I don't think it is suitable for this directly. (We can't use commas, for example, because I believe mIRC uses them to separate channel name and key.)

With that, I am unsure what benefit it would serve to have a new scheme/syntax for this. We could certainly support it via x-cz: (which I plan to introduce for other things), but I don't yet see the usefulness.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk

Comment 3

10 years ago
So this is WONTFIX for irc:// urls at least. Feel free to reopen/morph once we have x-cz: urls if this is still desireable. Adding an extra url type just for this bug seems nonsense to me, and I also don't see the use of having this new URL scheme for IRC stuff if we're the only IRC client to support the scheme (I can see we may need it for other things, but not *only* as some strange non-standard alternative to irc:// ).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.