If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

context menu in textarea dows not always work at the beginning of a word (as separated by whitespace)

RESOLVED DUPLICATE of bug 357467

Status

()

Core
Spelling checker
--
trivial
RESOLVED DUPLICATE of bug 357467
10 years ago
8 years ago

People

(Reporter: Gernot Hueller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

There seem to be problems with context menus in text areas at the beginning of a "word" ie after a whitespace character.
I use ctrl-left + ctrl-right frequently to navigate between words.

for example, if this text is written in the first line of a text area (excluding quotes) (with en-us dictionary installed and enabled)
"I use ctrl-left + ctrl-right "
context menu on the left "ctrl" has no spell checker result, but context menu for the right "ctrl" does.
try also the following line ie enable en-us spell checker, write the line without quotes in a textarea and open context menu between the first letter of an underlined word and the space left to it-either by mouse or keyboard.
"the quick bron fox jumps oer tthe lazy dog."
results look nondeterministic, don't they?

Reproducible: Always

Steps to Reproduce:
1.enable en-us dictionary
2.go to a web page which has a text area
3.paste this text into the text area: the quick bron fox jumps oer tthe lazy dog.
4.move caret/click mouse just left of the "b" in "bron"
5.open context menu
Actual Results:  
context menu WITHOUT spell checker results

Expected Results:  
context menu WITH spell checker results
Assignee: nobody → mscott
Component: General → Spelling checker
Product: Firefox → Core
QA Contact: general → spelling-checker

Updated

9 years ago
Assignee: mscott → nobody

Comment 1

8 years ago
Using the "ctrl-left + ctrl-right" testcase, I notice that the region for which right-clicking brings up the menu is slightly different for each "ctrl" 

On the left ctrl, it starts in the middle of the c, while on the right ctrl, it starts midway through the previous space. 

On the other side of the word, it starts midway into the character after "l".

Confirming. While very minor, there is still an editor bug here.
Severity: minor → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357467
You need to log in before you can comment on or make changes to this bug.