If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No style sheet loaded for Chinese version of page

RESOLVED DUPLICATE of bug 312179

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 312179
10 years ago
10 years ago

People

(Reporter: Daniël Mantione, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.5 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); nl; rv:1.8.1) Gecko/20061023 SUSE/2.0-30 Firefox/2.0

www.freepascal.org is a multi-lingual website with content negotiation. Recently a Chinese translation was added, which doesn't render with style sheets in Firefox:

http://www.freepascal.org/fpc.html.zh-CN

All other language versions of the pages, for example the English ones render okay, i.e.:

http://www.freepascal.org/fpc.html.en

There is no difference in html between the languages, just the language and encoding differs. Konqueror, Opera and IE render the Chinese page correctly.


Reproducible: Always

Steps to Reproduce:
Browse to the page.
Actual Results:  
The page renders, with Chinese characters, but the style sheet is ignored.
For some readon the stylesheet is throwing the following errors, but line 1 is a comment so I'm not sure what's happening:

Warning: Unexpected end of file while searching for ',' or '{'.  Ruleset ignored due to bad selector.
Source file: http://www.freepascal.org/css/fp.css
Line: 1
 ----------
Warning: Unexpected end of file while searching for closing } of invalid rule set.
Source file: http://www.freepascal.org/css/fp.css
Line: 1
 ----------
Warning: Unexpected end of file while searching for ',' or '{'.  Ruleset ignored due to bad selector.
Source file: http://www.freepascal.org/css/fp-navl.css
Line: 1
 ----------
Warning: Unexpected end of file while searching for closing } of invalid rule set.
Source file: http://www.freepascal.org/css/fp-navl.css
Line: 1
Ah, see bug 312179 comment 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312179
(Reporter)

Comment 3

10 years ago
Reopened because:
* My comment about HTTP ISO-8859-1 default in bug 312179.
* The document contains a BOM, which according to the CSS 2.1 spec should have a higher priority than the encoding of the referring document.

For practical purposes it is desirable to simply add the encoding to the page, which I will do shortly, however, this will mean the URL posted will no longer be useable for testing purposes.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Your html page is sent with a charset, a UTF-16 charset (note the html spec about priorities of specified encodings). Thus the css encoding defaults to that. The css file does not contain a BOM so there is no extra information there to follow.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312179
You need to log in before you can comment on or make changes to this bug.