DnD link to save linked resource

RESOLVED WONTFIX

Status

Camino Graveyard
Drag & Drop
--
enhancement
RESOLVED WONTFIX
11 years ago
4 years ago

People

(Reporter: Christoph Päper, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.4) Gecko/20070509 Camino/1.5 (MultiLang)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.4) Gecko/20070509 Camino/1.5 (MultiLang)

Dragging a link to the Finder (Explorer etc. if applicable for other OSs) with a certain modifier key (Alt/Option, Shift or Command/Meta) hold own should download the linked file and not create a mere shortcut.

Reproducible: Always

Steps to Reproduce:
1. Drag a link (e.g. one pointing to an image file),
2. Press and hold any of the keys mentioned
3. Drop to a Finder window (incl. the Desktop)
Actual Results:  
A weblink is created, no matter which modifier key was or keys were used, just like none had been used.

Expected Results:  
At least one modifier key should have resulted in the linked file being downloaded to the volume.

Comment 1

11 years ago
We could certainly consider using option-drag to trigger a file promise.

Comment 2

11 years ago
Yeah, option-drag seems to make a lot of sense for this since option-click does essentially the same thing and option-drag in the Finder duplicates the file being dragged, so there's fairly strong OS precedent for it.

Comment 3

11 years ago
Confirmed.  This is a very Maclike behavior.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.