No window gets the focus when loading a URL from an external application.

VERIFIED FIXED in Firefox 3 beta1

Status

()

Firefox
Shell Integration
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: faaborg, Assigned: mossop)

Tracking

({regression})

Trunk
Firefox 3 beta1
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
I tested on OS X and Vista, here are the steps to reproduce

1.  Open minefield, and another window (download manager, add-ons manager)
2.  Give another application the focus
3.  Open a URL from an external app (shortcut to a web page, URL in a RSS reader, etc.)

Minefield will load the page, but none of the minefield windows will have the focus.  On OS X the last window to have the focus (like the download manager, or add-ons manager) will get the focus back, instead of focus going to the browser window loading the page.
Is this a regression?
(Reporter)

Comment 2

11 years ago
>Is this a regression?

This is a regression from Firefox 2, but I'm not sure when it occurred.
Keywords: qawanted, regression
OS: Mac OS X → All
Hardware: PC → All
I suspect this is a front-end issue (since the front end is what knows that a load came from an external app, and would thus have to do the focusing desired here).  But please do reassign back to docshell if there is evidence that this is a docshell problem.
Component: Embedding: Docshell → OS Integration
Product: Core → Firefox
QA Contact: docshell → os.integration
Flags: blocking-firefox3?

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+

Updated

11 years ago
Target Milestone: --- → Firefox 3 M8
Duplicate of this bug: 390838

Updated

11 years ago
Target Milestone: Firefox 3 M8 → Firefox 3 M9

Comment 5

11 years ago
Marcia-  can you look at this one and resolve the qawanted?  They are looking for a regression range.
(Assignee)

Comment 6

11 years ago
Created attachment 284918 [details] [diff] [review]
patch rev 1

It looks like whatever changed simply stopped us automatically focusing new tabs on opens in background windows, which I think is the right thing anyway.

This patch just focuses the new tab if it is not a background open. This brings us to the same behaviour as Bon Echo.

There is still an issue with background loads where the app still receives focus on OSX, but that also occurs on Bon Echo and I suspect is a widget related issue or something.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #284918 - Flags: review?(gavin.sharp)

Updated

11 years ago
Whiteboard: [has patch][need review gavin]
Any chance we could get a regression range for this?
(Assignee)

Comment 8

11 years ago
Created attachment 285082 [details] [diff] [review]
patch rev 2

This is a regression from bug 348369 however to keep that fixed we should only focus the window if the load was external.
Attachment #284918 - Attachment is obsolete: true
Attachment #285082 - Flags: review?(gavin.sharp)
Attachment #284918 - Flags: review?(gavin.sharp)
Attachment #285082 - Flags: review?(gavin.sharp) → review+
Whiteboard: [has patch][need review gavin] → [has patch]
Whiteboard: [has patch] → [has patch, review]
(Assignee)

Updated

11 years ago
Whiteboard: [has patch, review] → [has patch][has reviews]
(Assignee)

Comment 9

11 years ago
Checking in browser/base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v  <--  browser.js
new revision: 1.873; previous revision: 1.872
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: qawanted
Resolution: --- → FIXED
Whiteboard: [has patch][has reviews]
verified fixed using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007102404 Minefield/3.0a9pre and Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007102407 Minefield/3.0a9pre. I verified by following the STR in the initial report and launching a link from Thunderbird.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.