Closed Bug 385914 Opened 14 years ago Closed 13 years ago

ICS provider using file: protocol tries to read disabled calendars causing error messages

Categories

(Calendar :: Provider: ICS/WebDAV, defect)

Sunbird 0.5
x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: v.solnicky, Unassigned)

Details

Seen on Sunbird 0.5 rc2 and some nightly build before. Checked only on Linux (tar.gz files, no installer).

I have a few (10-15) local calendars attached via ICS provider (file:/local/path.ics). At least on some of them Sunbird complains although they are not checked in the calendar tab it they should be ignored. But they are being read and processed causing error reports. The mistakes are all regarding unexpected UTF-8 character (the files originated in Sunbird 0.2).

I cannot say if it happens on Windows, nether can I say it happens in Lightning.

While writing this I recalled I should check if they use file://localhost/path/file.ics, file:///path/file.ics or file:/path/file.ics -- I know I have used all forms before.

Let me know if you have any other questions; unfortunately I cannot promise quick answer as the vacation time is approaching.
As I understand it (using Lightning on Windows), all calendars are read and processed regardless of whether the checkboxes are enabled in the Calendars tab.  The checkboxes only determine whether the events are shown in the calendar views, not whether the calendars are processed.  This behavior is useful for those of us who have recurring alarms about which we want to be reminded, but don't want the events to be visible in the views because that would clutter the views.

It seems to me that the errors that you're receiving are a problem, but are not directly related to whether the checkboxes are enabled.
(In reply to comment #1)

Yes, it may have been that I missed the meaning of the check box. Maybe the people who perform the usability analysis should tell their opinion. The check box column  does not have any heading thus I had no chance to find if it was true or not. But it works consistently for http: protocol as well (I have just tried it).

By the way, the calendars that are processed use both the notation

file://localhost/path/to/the/file.ics

and

file:///path/to/the/file.ics

so this is a consistent behaviour.

Should I changed it to a request for enhancement to have an ability to disable a calendar without deleting it?
(In reply to comment #2)
> Yes, it may have been that I missed the meaning of the check box. Maybe the
> people who perform the usability analysis should tell their opinion.

I think this bug is INVALID. Please resolve it if you agree with me. The UE experts can comment on your request for enhancement.

> Should I changed it to a request for enhancement to have an ability to disable
> a calendar without deleting it?

Please file a separate UNCONFIRMED request for enhancement.
Just a suggestion for the new bug, Vladimír, perhaps there should be two checkboxes:  one in the calendar list to enable/disable whether the calendar is loaded/processed at all, and another in the Properties dialog to specify its visibility in the views.

I agree that it would be useful to be able to prevent calendars from loading (especially large shared remote calendars that you rarely use or that contain errors).
Keywords: qawanted
Whiteboard: [qa discussion needed]
Target Milestone: 0.7 → ---
Resolving INVALID per comment#3
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
Whiteboard: [qa discussion needed]
You need to log in before you can comment on or make changes to this bug.