Messenger: Twisties next to the folders which don't have subfolders

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: huang, Assigned: scottputterman)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Used 05-08-09-M16 commercial build all platforms:

Twesties next to the folders which don't have subfolders.

1) Login to Mail Account
2) Select the folders (which without the subfolders)
3) Twesties display next to the folders which don't have subfolders.


Expected results: Shouldn't display the twesties when folders without the 
subfolders.

Comment 1

19 years ago
Theres is no harm when clicking on the twisties.
Keywords: regression
Summary: Twesties next to the folders which don't have subfolders → Twisties next to the folders which don't have subfolders
(Assignee)

Comment 2

19 years ago
reassigning to rjc.  Your changes to tree.css caused this.  When I backed them 
out, I could make Linux work again. For some reason I'm not seeing this on 
Windows.
Assignee: putterman → rjc

Comment 3

19 years ago
This is a per-platform issue.  At least on Mac, even empty folders get 
twisties... and I'd argue that we should do the same on all platforms. Either 
way though, I'm re-assigning this bug to ben to "do the right thing".

Not having these twisties causes users to be unable to drag&drop bookmark items 
around into empty folders and messes up bookmarks, by the way.  <sigh>
Assignee: rjc → ben

Comment 4

19 years ago
mark nsbeta2 as it can lead to confusion.  Very noticeable area.  
(Assignee)

Comment 5

19 years ago
I agree that we want a resolution, but I think having useable mail is pretty 
important. I'd like to see this resolved soon, if not by tomorrow.  I'm not 
against backing out the changes to tree.css until this is resolved.

I'm not a Mac UI person, but if it ends up this way on Windows I think it will 
be very bad.

Comment 6

19 years ago
How does this affect mail *usability* ?

Comment 7

19 years ago
It affects mail usability in that all folders, including newsgroups, have a 
twistie next to do regardless of whether there are subfolders are not.  
Folders/newsgroups is one of the most noticeable areas of mail.  From almost 
every version of Navigator / Communicator, a twistie is used to designate that 
something has a child.  If we start displaying twisties when there are no 
children present of a selected item, this makes the use of twisties meaningless 
to designate that something has a child which can be expanded/collapsed.
Keywords: nsbeta2

Comment 8

19 years ago
> From almost every version of Navigator / Communicator, a twistie is used to 
designate that something has a child.

Again, not on any Mac version of Navigator/Communicator... which is why I said 
that this is a platform issue, and assigned the bug to Ben.

Overall, I'm not as interested in what previous versions of the product did as 
much as I am interested in we do the "right thing" for each platform... and I 
hope that Ben agrees.

In the short term, you can certainly back out the change. [However, you'll be 
re-exposing various other bugs (including, as I mentioned, bugs with 
bookmarks).] 

Perhaps an agreeable middleground is for this mail/news issue to be fixed in 
"mail-local CSS"?

Comment 9

19 years ago
yes, we should do the right thing (expected behavior) for each platform.  I 
guess I was mistaken for the Mac, but I have to note that in 4.72 for Mac, I 
don't see twisties when an item has no subfolder.  I was only using past 
products to explain why I think usability for the user would be affected.

I'll leave up to you guys to decide what is right.
> I guess I was mistaken for the Mac, but I have to note that in 4.72 for Mac, I 
don't see twisties when an item has no subfolder.

Hmm... are you looking at Mail folders in 4.72?  I'm running 4.73 and looking at 
Bookmark Folders.  Also, *empty* folders in both the Mac's Finder as well as 
other Mac apps still get twisties.

Comment 11

19 years ago
Robert - yes, I was looking at this on the Mac Comm. 4.72.  I actually asked 
Peter Mock to confirm it for me.  

Comment 12

19 years ago
Robert,

Yes, we are looking at the mail folders list located in the 3 pane/2 pane view 
of messenger. In Communicator 4.72, Messenger only displays twisties next to 
mail folders when there are sub-folders located within the folders.  In the Edit 
 Bookmark window, I see twisties next to each bookmark folder regardless if the 
folder contains bookmarks or not.

It's important to note that you are changing the folder behavior for Mail 
between 4.7x and 5.0.  It looks very strange to see twisties next to reserve 
folder (Inbox, Drafts, Template, Trash, Unsent Messenges) and user created 
folders.  Our 4.0 mail server don't support creating folders under the reserve 
folders.  I don't see why we should display them if they don't serve a purpose. 
 This present a usuablity issue because if I was connecting to a Cyrus mail 
server that only allows subfolders in the Inbox, I would be very confused why 
there are twisties.

My question is why can we keep the same behavior as 4.0 to 4.7x?  I am not 
trying to say how the folders should be in the Manage Bookmark window.  I am 
only concern about what it looks like and behaves in the Messenger window.  If I 
didn't know about this bug and looked at my mail folder list, I couldn't tell 
what folders contained subfolders and which one didn't until I clicked on the 
folder. Can you give me reason(s) why mail behavior should be changed just 
because you want to keep the same functionality for bookmarks?  I think they 
should be treated separately.  (my 2 cents.)

Comment 13

19 years ago
fyi,
 This issue affects mail on windows and linux too.  Changing platforms to "all". 
Adding the word Messenger to title.
Hardware: PC → All
Summary: Twisties next to the folders which don't have subfolders → Messenger: Twisties next to the folders which don't have subfolders
(Assignee)

Comment 14

19 years ago
reassigning to me.  I'm just going to override this in our trees in mailnews.  
it looks silly right now.  It's not worth spending more time fighting over.  If 
I can get it to work I will just leave it as it and let anyone who cares fight 
over the bookmarks window which will still look strange on Windows but not 
strange enough to really matter.  My main concern here is that it's been working 
this way for the last 1.5 years in mail and it got broken yesterday.
Assignee: ben → putterman

Comment 15

19 years ago
IMO, it's mandatory that mail folders without children do not show the twistie.
The correct analogy is that mail folders without twisties are leaves in the
tree, just as individual bookmarks are leaves in the bookmarks tree. I can
certainly see how you might want to have twisties on bookmark folders without
children, but bookmark folders without children are so rarely used that I don't
really care. OTOH, mail folders without children are the typical case, and
making the typical case look like the edge case is just bad UI, IMO. I'd be
happy to talk more about this if necessary.
(Assignee)

Comment 16

19 years ago
I checked in the fix.  Mail windows no longer have twisties where there 
shouldn't be any.  If we decided to make this the default behavior, someone 
should remove these from mailnews files.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 17

19 years ago
Thanks Scott!
(Reporter)

Updated

19 years ago
QA Contact: lchiang → huang

Comment 18

19 years ago
This works in Win32 build 05-09-09.  Need to check on other platforms.
(Reporter)

Comment 19

19 years ago
Verified on all the platforms:
OK on WinNT 05-09-09-M16
OK on Mac 05-09-08-M16
OK on Linux 05-09-08-M16

Marking as verified.
Thanks Lisa for finding this bug and Scott for fix this bug!!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.