Ok button does not close settings window when pressed, but changes are saved.

RESOLVED DUPLICATE of bug 368617

Status

--
minor
RESOLVED DUPLICATE of bug 368617
11 years ago
7 years ago

People

(Reporter: py2elg, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070509 SeaMonkey/1.1.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070509 SeaMonkey/1.1.2

Ok button in Mail & Newsgroups Account Settings does not close the window when pressed, but changes are saved.

Reproducible: Always

Steps to Reproduce:
1.Open Mozilla Mail (Seamonkey)
2.Select Edit->Mail & Newsgroup Settings
3.Change anything
4.Press OK Button
Actual Results:  
Form Window does not close. The forms closes only if you click on the X button.

Expected Results:  
Form closing.

Comment 1

11 years ago
You're talking about SeaMonkey 1.1.2 right? Just wondering because of Bug 383938 (which was trunk-only).
(Reporter)

Comment 2

11 years ago
Yes.

Thanks.

Comment 3

11 years ago
See also Bug 368617 (duplicate?)
Edson,

Can you reproduce with SeaMonkey v1.1.9 ?
Version: unspecified → SeaMonkey 1.1 Branch

Comment 5

10 years ago
Hello guys!
I've had this problem (or at least similar) and found a temporary solution.
On my system (OpenSUSE, Thunderbird 2.0.0.4) I had the error:

Error: [Exception... "Component returned failure code: 0x8000ffff
(NS_ERROR_UNEXPECTED) [nsISpamSettings.initialize]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://messenger/content/AccountManager.js :: saveAccount :: line 648"  data:
no]
Source File: chrome://messenger/content/AccountManager.js
Line: 648

There I found a line that says:

 // if we made account changes to the spam settings, we'll need to re-initialize
 // our settings object
 if (server && server.spamSettings)
    server.spamSettings.initialize(server);

Now this line, that wants to initialize the spamSettings (AFAIK), is sometimes broken. In my case, I can reproduce this bug with just browsing around the settings window (vieweing settings a lot, like 20 or more pages), and then the OK button is broken, and the error comes. So my solution wants to be, to put a try - catch in this line like this:

 // if we made account changes to the spam settings, we'll need to re-initialize
 // our settings object
 if (server && server.spamSettings) {
    try {
        server.spamSettings.initialize(server);
    } catch(err) {
        // Handle errors here, or at least inform the user to restart
        //hunderbird to make Spam settings work as he just set it up.
    }
 }

I hope I could help,
regards
Gregory

Comment 6

7 years ago
WORKSFORME
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111017 Firefox/10.0a1 SeaMonkey/2.7a1

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 368617

Updated

7 years ago
Assignee: mail → nobody
QA Contact: mailnews-account
Whiteboard: [Halloween2011Bug]
You need to log in before you can comment on or make changes to this bug.