:first-line negates :hover css declaration

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: D. Nicholls, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

If a p element has a :first-line style, the :hover style will only be applied to the first a / link. Interestingly enough, I found a page online that exhibits the same effect while attempting to show an old Gecko bug (multiplying links--this page is linked, above) which does not show up in Firefox.

I found the bug using an external stylesheet, while the example page uses embedded styles.

This error does not happen in IE 6 or 7.

Reproducible: Always

Steps to Reproduce:
1.Set p:first-line and p a:hover style declarations.
2.Create a p with more than one contained a link.
3.Hover over the element's links.
Actual Results:  
Links subsequent to the first in an element will not exhibit :hover styles.

Expected Results:  
All links should exhibit :hover styles.

Comment 1

11 years ago
Could you attach a minimized testcase?
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.8 Branch

Comment 2

11 years ago
Broken in 2.0.0.4, but works fine in a trunk build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Flags: in-testsuite?
(Reporter)

Comment 3

11 years ago
Created attachment 271068 [details]
minimized testcase

Sorry it's late. Please review it again.
(Reporter)

Comment 4

11 years ago
Should I not worry, btw, if it's just 2.0.0.4? I'm just a wee html/css guy, and am trying to help, but am brand new to this. Seems that, since that's the latest release, it should still be addressed, though.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

11 years ago
At this point, it really doesn't matter that it's not working in 2.0.0.4... the chances of us taking a fix for something like this on that branch are basically nil.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.