Crashed after minimize/open the Mail from the bottom system tool bar

VERIFIED FIXED in M16

Status

defect
P1
critical
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: huang, Assigned: danm.moz)

Tracking

({crash, platform-parity})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+] possibly fixed by pinkerton, bug #38872)

Crashed after minimize/open the Mail

Used 05-08-09-M16 commercial build

Got crashes after minimize/open the Mail.

Can be reproduced every time.

1) Open browser
2) Open & Login to Mail (IMAP Mail)
4) After read some messages
5) Minimize Mail to the bottom and open again.
6) Crashed.

Expected results: Shouldn't crash after Minimize & open Mail.
Talkback ID: 10130978, 10130279, 10130358

10130978 Stack Trace:

0x000000c3 
nsMenuPopupFrame::GetNearestEnclosingView 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuPopupFrame.cpp, line 226] 
nsMenuPopupFrame::SyncViewWithFrame 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuPopupFrame.cpp, line 483] 
nsPopupSetFrame::LayoutFinished 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsPopupSetFrame.cpp, line 385] 
nsPopupSetFrame::Layout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsPopupSetFrame.cpp, line 236] 
nsSprocketLayout::Layout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 365] 
nsContainerBox::Layout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 525] 
nsBoxFrame::Layout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 822] 
nsStackLayout::Layout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsStackLayout.cpp, line 237] 
nsContainerBox::Layout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 525] 
nsBoxFrame::Layout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 822] 
nsBoxFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 678] 
nsRootBoxFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsRootBoxFrame.cpp, line 207] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
666] 
ViewportFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 546] 
PresShell::ResizeReflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1684] 
PresShell::ResizeReflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3455] 
nsViewManager2::SetWindowDimensions 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 437] 
nsViewManager2::DispatchEvent 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1293] 
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69] 
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 531] 
nsWindow::DispatchWindowEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 548] 
nsWindow::OnResize [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, 
line 3258] 
nsWindow::ProcessMessage 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2670] 
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 781] 
USER32.dll + 0x19d0 (0x77e719d0) 
USER32.dll + 0x30a3 (0x77e730a3) 
ntdll.dll + 0x163a3 (0x77f763a3) 
DocumentViewerImpl::SetBounds 
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocumentViewer.cpp, line 691] 
nsDocShell::SetPositionAndSize 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 1393] 
nsWebShell::SetPositionAndSize 
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 1610] 
nsWebShellWindow::HandleEvent 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 414] 
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 531] 
nsWindow::DispatchWindowEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 548] 
nsWindow::OnResize [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, 
line 3258] 
nsWindow::ProcessMessage 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2670] 
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 781] 
USER32.dll + 0x19d0 (0x77e719d0) 
USER32.dll + 0x30a3 (0x77e730a3) 
ntdll.dll + 0x163a3 (0x77f763a3) 
USER32.dll + 0x18d2 (0x77e718d2) 
nsWindow::DefaultWindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 807] 
USER32.dll + 0x27fe (0x77e727fe) 
USER32.dll + 0x2889 (0x77e72889) 
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 792] 
USER32.dll + 0x1820 (0x77e71820) 
Keywords: crash
Whiteboard: dogfood,
I can't reproduce this but it looks like it's crashing in xp toolkit code. 
reassigning to trudelle.
Assignee: putterman → trudelle
This is on Win32.
I am able to reproduce this as well.
Keywords: dogfood
Whiteboard: dogfood,
This is not occurring on Linux & Mac, not try on Win98 yet. Adding pp anyway.
Keywords: pp
I am still getting this for today's build every time......
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]
I see the creash today on Win98.  reassigning to danm as p1 for M16
Assignee: trudelle → danm
Priority: P3 → P1
Target Milestone: --- → M16
danm -- I'm pretty sure this is FIXED by pinkerton yesterday -- he added a bunch 
of sanity checks to popup code for a crash that was occuring with this 'crash on 
maximize' scenario. (bug #38872).

huang, lchiang -- are you still seeing this crash in builds from may 12 on ...
Whiteboard: [dogfood+] → [dogfood+] possibly fixed by pinkerton, bug #38872
give mike a chance to claim victory ...
I remember that I tried this morning 05-12-10-M16 commercial build, problem is 
still occurring...but I will try on tonight's commercial build again....
I did tried on lastnight 05-12-21-M16 commercial build on Win98.
There is no crash anymore. But since this bug logged on WinNT, I need to try on 
the WinNT in office next Monday.

QA Contact: lchiang → huang
Resolving as fixed. Karen, could you retest this please?  If no crash, we should
at least reconsider the dogfood nomination.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
I did tried on WinNT on Monday -- no crash for this specific scenario.
But since there were radom crashes from this Monday to Wednesday commercial 
build, I didn't feel safe for closing this bug.
I did tried on today's 05-18-09-M16 commercial build, more safe for closing this 
bug now. 
Marking as verified!!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.