If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Not displaying the progress when downloading the IMAP messages headers

VERIFIED FIXED in M17

Status

MailNews Core
Networking: IMAP
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: Karen Huang, Assigned: Bienvenu)

Tracking

({polish, regression})

Trunk
x86
Windows NT
polish, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] ETA 6/27)

(Reporter)

Description

18 years ago
Not displaying the progress when downloading the headers

Used 05-08-09-M16 commercial build

1) Create new profile for IMAP mail account.
2) After Login to this IMAP mail account.
3) Actual Results: Not displaying the progress when downloading the 
messages headers

Expected results: Should display the the progress in the progress bar when 
downloading the messages headers.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → huang

Comment 1

18 years ago
We need to have this back so that the user can know the progress (particularly 
if the folder or newsgroup is large).
Keywords: nsbeta2, regression

Comment 2

18 years ago
I may have broken this last week when I landed some new progress changes.
Status: NEW → ASSIGNED
Target Milestone: --- → M16

Comment 3

18 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17

Comment 4

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.  Adding polish keyword.
Keywords: polish
Whiteboard: [nsbeta2-]
(Assignee)

Comment 5

18 years ago
I'll look at this.
Assignee: mscott → bienvenu
Status: ASSIGNED → NEW
(Assignee)

Comment 6

18 years ago
renominating for beta2. I have a very simple fix, reviewed. I personally would 
have said this is a dogfood bug (and I think getting progress and status 
messages working in the first place was a dogfood bug) - I find it hard to use 
the product when I can't tell what, if anything, it's doing.
Status: NEW → ASSIGNED
Whiteboard: [nsbeta2-]

Comment 7

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
(Assignee)

Comment 8

18 years ago
OK, I'll check in a fix Monday or Tuesday.
Whiteboard: [nsbeta2+] → [nsbeta2+] ETA 6/27
(Assignee)

Comment 9

18 years ago
progress is now displayed - having trouble with the meteors on imap folder load.
I'm still working on that, but the progress is fixed. If I can fix the meteors,
I'll check that in too.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

18 years ago
Yes. Progress is now displaying when downloading the IMAP messages headers. But
by using today's build, It seems that seamonkey still not displaying the
progress when downloading imap folders, should I close this bug and log another
bug for tracking the loading folders' problem? or wait for the later build with
the folders' fix and verify this bug later?
(Assignee)

Comment 11

18 years ago
what do you mean, "downloading imap folders"? We do show progress and status
messages downloading imap headers, but we don't download folders that I can
think of. We display status messages when discovering folders, I've seen that...
(Assignee)

Comment 12

17 years ago
*** Bug 26820 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 13

17 years ago
I think that I didn't describe clear from my above comment.
Copying Comments From David 2000-06-23 07:28

< having trouble with the meteors on imap folder load.

I think above is what I mean, I will mark as verified for this bug since this 
bug has been fixed by you. But David, do we have another bug for tracking above 
problem? I may need to log that for tracking that since I didn't see that from 
seamonkey (compare with Communicator 4.x). Correct me if I was wrong....
Marking as verified for this bug.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 14

17 years ago
I still don't know what the problem is. We do display status when downloading
message headers in imap folders, and we don't ever "download" imap folders.
(Reporter)

Comment 15

17 years ago
Sorry. My mistake -- I am not meaning "download imap folders".
When I used Communicator 4.x, I saw that when I first time open the new IMAP 
mail account, from the status bar will display "found xxxx(each folder_name)" 
very quickly from the status bar (I am thinking this  might be what you mean 
for "meteors on imap folder load"). But from seamonkey, it is only display 
"looking for folders", I am wondering to know whether seamonkey will follow the 
Communicator 4.x design or not?
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.