nsGtkRemotingService leaks a StringBuffer at shutdown

RESOLVED DUPLICATE of bug 336920

Status

()

Core
General
RESOLVED DUPLICATE of bug 336920
11 years ago
11 years ago

People

(Reporter: Robert Sayre, Assigned: Robert Sayre)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

11 years ago
 
(Assignee)

Comment 1

11 years ago
Created attachment 269972 [details] [diff] [review]
truncate it
Assignee: nobody → sayrer
Status: NEW → ASSIGNED
Attachment #269972 - Flags: superreview?(roc)
Attachment #269972 - Flags: review?(roc)
(Assignee)

Comment 2

11 years ago
Created attachment 269973 [details] [diff] [review]
truncate it

oops, copy-paste-o
Attachment #269972 - Attachment is obsolete: true
Attachment #269973 - Flags: superreview?(roc)
Attachment #269973 - Flags: review?(roc)
Attachment #269972 - Flags: superreview?(roc)
Attachment #269972 - Flags: review?(roc)
I'm confused. Don't we run destructors on service objects?
(Assignee)

Comment 4

11 years ago
Well, we're leaking nsGtkToolkit as well. Could that cause this?
(Assignee)

Comment 6

11 years ago
This is only called from XRE_main. Will we destroy a service properly from there? (I verified that the destructor never runs)

http://lxr.mozilla.org/seamonkey/source/toolkit/xre/nsAppRunner.cpp#2800
I'm not sure, ask someone who knows more about XPCOM shutdown?
(Assignee)

Comment 8

11 years ago
bsmedberg, any clues here?
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 336920
(Assignee)

Updated

11 years ago
Attachment #269973 - Flags: superreview?(roc)
Attachment #269973 - Flags: review?(roc)
You need to log in before you can comment on or make changes to this bug.