Unable to Close Tab in Thunderbird 3.0a1pre (20070627)

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Nir, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 

Clicking on 'X' on tab fails to close Tab and generates this error message in Error console :

"Error: tabbedBrowser has no properties
Source File: chrome://global/content/bindings/tabbrowser.xml
Line: 3132"

But right clicking on Tab and selecting 'Close Tab' successfully closes Tab.

Reproducible: Always

Steps to Reproduce:
1.Right click on a message 
2.Select open message in new tab
3.click on 'X' button on tab
Actual Results:  
Tab doesn't close ( seems like it reloads instead of close )

Expected Results:  
Tab should be closed.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

11 years ago
This problem can be successfully reproduced in safe mode.

Also on start Thunderbird shows this error message in error console :

"Failed to load XPCOM component: /mnt/Work_Data/Thunderbird-3a1pre/components/XPCOMUtils.jsm"

Also when close button is clicked , linux console shows this message 

(when I have selected a folder to open in tab)
"selecting folder news://news.mozilla.org/mozilla.support.firefox"
(when clicked on 'X' button)
"finding row for folder news://news.mozilla.org/mozilla.support.firefox row = 17"
Keywords: regression

Comment 2

11 years ago
since tabs are a brand new feature, this can't be a regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 3

11 years ago
Seems there's a wip patch in bug 218999 for this.
(Reporter)

Comment 4

11 years ago
Can't reproduce this problem after today's update.  Marking as FIXED
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.