msdn.microsoft.com - It's impossible to see russian characters on the left MSDN-tree. But IE works fine.

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: Dmitry, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

It's impossible to see russian characters on the left MSDN-tree on site: 

http://msdn.microsoft.com/library/rus/ 

But IE works fine with this page.

Russian characters in Firefox are as "?".

Reproducible: Always

Steps to Reproduce:
1. Open URL above.
2. See bug.
3. Let's crying... ;-)
Actual Results:  
Russian characters on the left part of HTML-page are as "?"-character.

Expected Results:  
Correct russian characters.
(Reporter)

Comment 1

11 years ago
Created attachment 270056 [details]
Bug's sreenshot
Unfortunately, that's not because we misrender what they send us, it's because they send us a broken page, and IE an unbroken page: if you load the URL for that part of the frameset (added to this bug's URL field) in IE, you get the same strings of "???" you get in Firefox. Loading /library/rus/ in IE, after all the browser detection you wind up with something else in that frame.
Assignee: nobody → english-us
Component: Tabbed Browser → English US
Product: Firefox → Tech Evangelism
QA Contact: tabbed.browser → english-us
Summary: It's impossible to see russian characters on the left MSDN-tree. But IE works fine. → msdn.microsoft.com - It's impossible to see russian characters on the left MSDN-tree. But IE works fine.
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> Unfortunately, that's not because we misrender what they send us, it's because
> they send us a broken page, and IE an unbroken page: if you load the URL for
> that part of the frameset (added to this bug's URL field) in IE, you get the
> same strings of "???" you get in Firefox. Loading /library/rus/ in IE, after
> all the browser detection you wind up with something else in that frame.

What are you talking about? Firefox has this bug in all situation when you go to this page, including when you go by links from www.microsoft.com. IE always show this page correctly. And Firefox alway show it with errors, even when correct Russian codepage or Russian autodetect mode set. I open full HTML page, not one frame, and I want browser to work fine.

Comment 4

10 years ago
You see, in the 'broken' version there's no Cyrillic characters at all, only question marks in their place.  Microsoft webmasters should fix this, not Mozilla.

Comment 5

10 years ago
this is also a dup of bug 287704 from 2005...
(Reporter)

Comment 6

10 years ago
But in IE all is ok! Firefox have to work correct if it's possible. And it's possible!

Comment 7

10 years ago
Do you understand that Firefox receives already-corrupted data from Microsoft web server?
(Reporter)

Comment 8

10 years ago
But IE receives correct data. Firefox must work the same as IE because it's correct and possible.

Comment 9

10 years ago
Dmitry, IE is *served* correct data.  Firefox isn't.  There's nothing you can do in Firefox.

But you can use the feedback form at http://www.microsoft.com/Rus/Feedback/GeneralQuestion.aspx to report the problem, as I've done just now.
(Reporter)

Comment 10

10 years ago
If IE can *serving* with correct data - Firefox can and must do it as IE.

Comment 11

10 years ago
Dmitry, I don't think you're grasping the concept here.

The Web server is sending content X to IE.

The Web server is sending content Y to Firefox.

Content X is correct. Content Y is not.

Firefox has absolutely ZERO control over what content it is being given by the Web server. The Web server is sending Firefox broken content.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 12

10 years ago
By the way, the original page seems to be 404, but the new Russian site at

http://msdn.microsoft.com/ru-ru/default.aspx

seems to work fine (no ? characters) in both Camino trunk and Firefox 2. I'm marking this FIXED, since it's clear there was indeed a bug at one point.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.