Important beer site doesn't print correctly

RESOLVED WORKSFORME

Status

()

Core
Print Preview
RESOLVED WORKSFORME
11 years ago
6 years ago

People

(Reporter: jtd, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
Original bug:
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=5659

Steps:

1. Open the URL
2. Select Print from the File menu
3. In the Print dialog, click Preview

Result: graphics display incorrectly on the third page and subsequent parts of the page render over six pages.  Safari prints everything in three pages.
(Reporter)

Comment 1

11 years ago
Created attachment 270063 [details]
jumbled graphics on page 3 of preview

Updated

11 years ago
Assignee: nobody → sharparrow1

Comment 2

11 years ago
Created attachment 270124 [details]
Simplified testcase

Hmm, I really have no clue how to approach this bug...

Comment 3

11 years ago
Created attachment 270125 [details]
Correct version of testcase

Oops, posted the wrong one.
Attachment #270124 - Attachment is obsolete: true
(Reporter)

Comment 4

11 years ago
Not sure the simplified testcase really matches the complexity of the original.  We need to figure out why something that should print out in 3 pages (see Safari) prints out in 9 instead.  Looks like the problem starts where the graphics are jumbled with the text (see screenshot).  Might just be bad HTML but it looks like something more than just that.

Updated

11 years ago
Depends on: 386147

Comment 5

11 years ago
No, it doesn't match the complexity of the original; I'll fix the issues in the testcase, then see if there are any issues left in the original site.

BTW, I have figured out why it prints to so many pages; see the patch in 386147.  I haven't figured out the overlapping text, though.

Comment 6

8 years ago
I was not able to reproduce this bug.

I did print-preview attachment 270125 [details].
It was 4 pages by
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090101 Minefield/3.2a1pre
It was 3 pages by
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090201 Minefield/3.2a1pre

Updated

8 years ago
Assignee: sharparrow1 → nobody
Note: Original bug (linked in comment 0) is now resolved as WORKSFORME.  I don't speak Japanese, so I don't know the details, but perhaps this instance of the bug should be resolved as well.

Comment 8

6 years ago
Seems the page no longer exists
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.