Closed Bug 386224 Opened 13 years ago Closed 13 years ago

Edit Draft & File | Send Link no longer populate the editor body

Categories

(Core :: DOM: Editor, defect)

defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: stephend, Assigned: peterv)

References

Details

(Keywords: regression)

Build ID: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070628 Minefield/3.0a6pre

Regression from bug 237964?  This worked in yesterday's build, but a lot has landed since then...

Summary: File | Send Link no longer populates the email message with the link

Steps to Reproduce:

1. Set Thunderbird as your default mail client (I haven't tested other apps)
2. From Firefox, do a File | Send Link
3. Examine the spawned Compose window

Expected Results:

Link is populated in the body of the email

Actual Results:

Link is missing.

I don't get any JS exceptions that are notable.
I just updated one of my trunk trees, and now I see this bug. I don't see it if I just update mail or mailnews, so I think it's something outside mailnews.
seems likely that it's the content editable changes.
OS: Windows Vista → All
Hardware: PC → All
edit draft is also broken.
There might be more regressions lurking but at least one:

nsHTMLEditor::DeleteNode now returns an error where it wasn't before. This snippet was added as part of the content editable changes to nsHTMLEditor::DeleteNode:

  // do nothing if the node is read-only
  if (!IsModifiableNode(aNode)) {
    return NS_ERROR_FAILURE;
  }

mail compose editor should be able to modify the node. maybe there's some new attribute we need to set on our editor shell, peterv might know if there is.

Here's a complete stack trace where we are trying to rebuild the editor document with our message content and getting denied in DeleteNode:

>	nsHTMLEditor::DeleteNode() Line 3888	C++
 	nsHTMLEditor::ReplaceHeadContentsWithHTML() Line 1698	C++
 	nsHTMLEditor::RebuildDocumentFromSource() Line 1766	C++
 	nsMsgCompose::ConvertAndLoadComposeWindow() Line 644	C++
 	nsMsgCompose::BuildBodyMessageAndSignature() Line 3930	C++
 	nsMsgCompose::InitEditor() Line 1459	C++
 	NS_InvokeByIndex_P() Line 102	C++
Summary: File | Send Link no longer populates the email message with the link → Edit Draft & File | Send Link no longer populate the editor body
(In reply to comment #4)
> maybe there's some new
> attribute we need to set on our editor shell, peterv might know if there is.

No, there isn't. I probably missed some spots in the editor that need to set the document as editable.
Assignee: nobody → peterv
Could someone try the patch in bug 386730 and see if it fixes this one? It looks like it at least fixed edit draft. The cursor seems to be missing, but that's a different bug.
yup, that fixes edit as draft and file | send link, thx!
Should be fixed by the patch for bug 386730.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified FIXED using Build identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/200708010404 Thunderbird/3.0a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.