Context-menu "Open in new window" s/b "Open Message in new Window"

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: John Morrison, Assigned: timeless)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description:
 If you have an HTML mail message that contains an <A HREF>, then 
 using the context menu "Open in new window" over the hyperlink 
 will (incorrectly) open the current message in a new mailnews window.

Steps to Reproduce:
1) mail http://bugzilla.mozilla.org/query.cgi to yourself
2) view this message in the 3pane window
3) right-click (context-click) over any hyperlink in the page
   and select "Open in new window"

Actual Results:
  The current mail message is opened in a new window 
  with mailnews chrome

Expected Results:
  The contents of the URL should by opened in a new window 
  with browser chrome

Reproducibility: always

Build Date & Platform Bug Found:
  2000050808 win95
  2000050811 linux
  2000050816 mac

Comment 1

18 years ago
actually, this is because we either have a wording problem or because I haven't 
implemented the part where mail functionality is removed from context menus when 
over html types.  Try using the menu item lower down "Open Link in New window" 
to get what you want.  The first one is doing the right thing but it should be 
called "Open message in new window". Sorry for the confusion.
(Reporter)

Comment 2

18 years ago
Ah, yes -- I hadn't noticed the other option in the context menu and had assumed 
that since this had the same position as in the browser context menu that it 
meant the same thing. 

I suppose though that the most common context-menu thing that I do in 4.x 
messenger is 'Open Link in New Window' so that is something of an argument 
for moving this to the top of the context menu in mailnews. 

As it stands though, "Open Link in New Window" over an HTML link results in 
a new browser window but the contents are 'about:blank' but I assume that this
is just not wired up yet.

Comment 3

18 years ago
jrgm - the 'about:blank' bug is a new one we filed today for URL dispatching.  
It will be fixed in tomorrow's build.
(Reporter)

Comment 4

18 years ago
Okay, so scratching my note re: about:blank, and this is just a matter of 
wording, option ordering, etc. So, you can keep this bug, or dup it, or close it 
out, now that I see it was pilot (semi-)error.

Comment 5

18 years ago
Changing summary to reflect actual bug.  Marking M18.
Summary: Context-menu "Open in new window" opens mail message instead of URL → Context-menu "Open in new window" s/b "Open Message in new Window"
Target Milestone: --- → M18

Comment 6

18 years ago
*** Bug 42472 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
marking nsbeta3 polish.
Keywords: nsbeta3, polish

Updated

18 years ago
Keywords: mail2
(Assignee)

Comment 8

18 years ago
reporter+jglick please check the url to clarify for me:
a) is the spec correct or does it need changing
b) what should be done
thanks.
Assignee: putterman → timeless
(Reporter)

Comment 9

18 years ago
Well, this is a mailnews decision, not mine. (Heh, but my two cents ... when
over an <A HREF> the message pane context menu should not be gratuitously 
dissimilar from the browser context menu -- e.g., the first menuitem should 
be the same in both: "Open Link in New Window". The "Open Message in New 
Window" should come later in the context menu. But that's just one 
opinion, etc.).

Comment 10

18 years ago
Sorry for the confusion. In the Thread Pane area, the context menu should have 
"Open Message in New Window".  In the message body, when over a URL, the context 
menu should have "Open Link in New Window". 

I will attach an updated copy of the spec to this bug. And see if I can get an 
engineer to post the updated spec to Mozilla also.

Comment 11

18 years ago
Created attachment 12381 [details]
Mail Menus spec

Comment 12

18 years ago
+ per mail triage
Whiteboard: [nsbeta3+]

Updated

18 years ago
Keywords: mailtrack
(Assignee)

Comment 13

18 years ago
accepting.
Status: NEW → ASSIGNED

Comment 14

17 years ago
Not holding PR3 for this; marking nsbeta3-. IMO, we really have bigger fish to
fry than this. If you're looking for a mail bug to help with, contact
selmer@netscape.com and he'll give you a good bug to work on.
Whiteboard: [nsbeta3+] → [nsbeta3-]

Comment 15

17 years ago
I'm pretty sure this is fixed.  We no longer put this in the message pane 
context menu and instead put Open Link as the first item.  It already says "Open 
Message in new Window" for the thread pane context.

Comment 16

17 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2
(Assignee)

Updated

17 years ago
Keywords: helpwanted, mozilla0.9
Target Milestone: M18 → mozilla0.9

Updated

17 years ago
Keywords: mailtrack

Comment 17

17 years ago
As far as I'm concerned, my Mozilla0.8 on win95 is correct:
In thread pane, the first context menu item is "Open Message in New Window"
In message pane, the first context menu item is "Open Link in New Window".
Can we mark this fixed?
(Reporter)

Comment 18

17 years ago
Looks fine to me. Timeless?
(Assignee)

Comment 19

17 years ago
seems fine w/ me.

News Message (one selected)
Open Message in New Window

i suppose we decided a long time ago to discontinue use of the term 'news 
posting'
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: helpwanted, mozilla0.9, nsbeta3, polish
Resolution: --- → FIXED
Whiteboard: [nsbeta3-]
Target Milestone: mozilla0.9 → M18

Updated

17 years ago
QA Contact: lchiang → nbaca

Comment 20

17 years ago
Build 2001-03-06-05: NT4,
Build 2001-03-06-08: Linux RH 6.2, Mac 9.04
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.