Closed Bug 386234 Opened 14 years ago Closed 14 years ago

decode non-ascii chars in location bar

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 105909

People

(Reporter: alaa, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070208 Mandriva/2.0.0.4-1mdv2007.1 (2007.1) Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070208 Mandriva/2.0.0.4-1mdv2007.1 (2007.1) Firefox/2.0.0.4

URLs in non ascii chars are now common due to wikis and and blogs generating URLs based on page titles.

but the URLs are unusable in their coded format, if I visit the mozilla page on Arabic WikiPedia the location bar shows
http://ar.wikipedia.org/wiki/%D9%85%D9%88%D8%B2%D9%8A%D9%84%D8%A7

as opposed to
http://ar.wikipedia.org/wiki/موزيلا

non-ascii URLs should be decoded on the location bar

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 105909
You need to log in before you can comment on or make changes to this bug.