If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Password no longer filled after some time on Google Analytics

RESOLVED DUPLICATE of bug 376668

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 376668
10 years ago
9 years ago

People

(Reporter: Francois Ingelrest, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20061201 Firefox/2.0.0.4 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20061201 Firefox/2.0.0.4 (Ubuntu-feisty)

I told Firefox to save my password for Google Analytics, but it seems to stop filling the field after some time. It works quite well for a few days (weeks?) and then all of a sudden when I open the page it stops filling the field. What's strange is that, if I fill the field myself, Firefox displays the master password dialog when I hit enter while it should display it upon page loading (I'm using the master password feature).

When this behavior happens, I have to remove the saved password from the preferences. Then Firefox asks me if I want it to save the password, and if I say yes it works correctly for some time. Then the same behavior occurs again...

Reproducible: Always

Steps to Reproduce:
1. See description

Actual Results:  
Firefox stops filling the password field

Expected Results:  
It should not
What's almost certainly happening here is that you've stored more than 1 Google account login (perhaps accidently, or due to some bug) when this starts happening, so when the page loads the password manager doesn't know which one to fill in automatically. [Instead we set up autocomplete entries on the username field, if it exists]. When you log in, the password manager checks the login you typed against the stored value (to see if you're changing you password), and at that point you'd get prompted for a master password.

You can verify this by quitting the browser when this starts happening, and looking in signons2.txt for entries for google.com.

A less likely cause might be if the form field names were changing, but think that would break Google logins for everyone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376668
(Reporter)

Comment 2

10 years ago
Thanks for your reply, I will check signons2.txt the next time it happens.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.