Window decorations dissapear when closing a PDF tab

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Nicholas Furgiuele, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070628 Minefield/3.0a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070628 Minefield/3.0a6pre

I've noticed that in today's trunk build of Minefield that when I close a tab showing an embedded PDF using Adobe Reader 8.1.0 destroys the window's decorations (title bar, window borders, etc).

* The window can still be resized using the resize handle on the bottom left hand side.
* Built in windows short cuts seem to no longer work in the window including "Ctrl + W" (when no tabs open)
* Right clicking the task bar icon does not show the shortcut menu
* Text boxes no longer accept input from the keyboard

This bug occurs when middle clicking the tab to close, when clicking the "X", when selecting "File > Close tab" and when pressing "Ctrl + W" on the tab.

Reproducible: Always

Steps to Reproduce:
1. Ensure that Adobe Reader 8.1.0 is installed
2. Open a new Firefox window to any URL
3. Open the following PDF document in a new tab
http://users.on.net/~distinctive/PDF_Document.pdf
4. Close the tab containing the PDF document
Actual Results:  
The window decorations, title bar, etc disappear, and windows functions such as shortcut keys, bringing a window to front, maximise, minimize, and text entry become unavailable.

Expected Results:  
Window decorations should remain and window shortcuts should function as normal.
This is WFM with:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008050906 Minefield/3.0pre

Reporter, is this still reproducible?

Comment 2

9 years ago
=> incomplete due to no response
if you still have a problem using a current release please comment in the bug 

(but WFM also Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081125 Firefox/3.1b2)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.